RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
2006-2009 Range Rover Classic
Joined
·
39 Posts
I had to post this. My lower glove box has been stuck for a month. Did the google thing; no luck. Went out with a screw driver today to pry it open a bit to see what I could see and I though bugger it, and hit the center about where the latch is with my fist 3 times; pressed the button and HEY PRESTO something had wedged inside I guess and put too much pressure on the latch.... Hope it helps.
 

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
102 Posts
I have the same issue, though it applies to both upper and lower glove boxes (compartments). I hear no sound at all when pressing the buttons to open. I plan to try your screwdriver, or might use a scribe to try and open.

If anyone else has any ideas, please do chime-in, as I have found little-to-nothing on fixing this issue searching the internet and this site.
 

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
102 Posts
I have the same issue, though it applies to both upper and lower glove boxes (compartments). I hear no sound at all when pressing the buttons to open. I plan to try your screwdriver, or might use a scribe to try and open.

If anyone else has any ideas, please do chime-in, as I have found little-to-nothing on fixing this issue searching the internet and this site.
Unfortunately had no luck trying to "jimmy"-open the glove boxes. Checked all of the accessible fuses, and did a hard re-boot by disconnecting the negative battery-lead.

Any assistance or guidance would be greatly appreciated.
 

·
Registered
Joined
·
11 Posts
Unfortunately had no luck trying to "jimmy"-open the glove boxes. Checked all of the accessible fuses, and did a hard re-boot by disconnecting the negative battery-lead.

Any assistance or guidance would be greatly appreciated.
did you solve this problem?
 

·
Registered
Joined
·
1 Posts
Unfortunately had no luck trying to "jimmy"-open the glove boxes. Checked all of the accessible fuses, and did a hard re-boot by disconnecting the negative battery-lead.

Any assistance or guidance would be greatly appreciated.
Hey Doc Same problem here!! I'm on the prowl now
 
1 - 5 of 5 Posts
Top