RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a 1998 2.5 Diesel P38
I will tell you a little story; I bought it like 4 weeks ago. When I bought it, the car did not move on 'D', only on 1. Once I reached 20km/h I could shift to D and it changed gears perfectly. I checked the oil, there was nothing in it, so I bought it.
Later I changed the oil, removed the valve body and cleaned the valves. New filter etc...
But it still did not move on D, only on 1, the oil was the correct amount now.
Well nevermind then I guess, I will disassemble the gearbox one day, I thought.
Now I did some other repairs on it (brake lines, parking light plugs...)
Once it was on the ground again I literally did Nothing on ECU or the tranny at all. It now moved on D with the display saying 'Gearbox Fault' . It enganged the gear violently at around 2500rpm. Then it moved.
Which tells me that I can exclude a mechanical damage, rather electrical.
I started the car again, afterwards I couldn't drive away on D, as before. Started again; "Gearbox fault" and moved away on D (Very slowly)
Did anybody else had the same problem? What might the problem here?
Thank you.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Yes I did look at it, the sprag clutch, I would have to disassemble it.
But why does it sometimes drive off on D, thats the interesting part. If the sprag clutch is broken, why does it drive off in a higher gear... and sometimes not...
 
1 - 4 of 4 Posts
Top