RangeRovers.net Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
Hey all, 96 p38.
I was on my way to my parents house yesterday when I jabbed the throttle hard and realesed it almost as quick. It seemed to lock its self into 3rd gear and disabled the manual/sport button. I shifted manualy to 1st and it did nothing (stayed in 3rd), I limped it to their house and left as I was late for an appointment with them. I got back about 5hrs later and got in the car, display said gearbox fault. I had all gears again and also the manual/sport button seemed to be working again as I tested it driving up the road from their house. I drove it home and the gearbox fault has not come back up. I've looked around (a bit) at some "gearbox fault" posts. I am pretty sure the alt. & Batt are fine. any ideas what can cause this? Has this happened to any one?
thanks
 

·
Registered
Joined
·
53 Posts
Discussion Starter #2
Can I get this sort of fault with a bad fuse box? mines startiing to go, the cabin filters got really plugged and burned a couple relay sockets. wondering if that could have caused a voltage problem of some sort with the trans.
 

·
Registered
Joined
·
401 Posts
Dead battery and/or corrosion on the terminals. Also check the fuse box under the hood and make sure the relays are not brown.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #4
rhino_ed said:
Dead battery and/or corrosion on the terminals. Also check the fuse box under the hood and make sure the relays are not brown.
Yeah the battery is fine, I've got a deep cycle thats fairly new and the alternator is working proper. I am leaning towards the fuse block, there is a burnt relay and i've seen the under side of those things once that starts to happen. I don't really feel like pulling it, has anyone every repaired one?
 

·
JACK'S GRANDAD
Joined
·
9,240 Posts
Just drop either a new one, or a known good used one in there. Shoot Scotty a PM, I believe he had one.
Also check the voltage on your TPS, they are known to play havoc with tranny's on every other vehicle...

Martin
 

·
Registered
Joined
·
53 Posts
Discussion Starter #7
rrtoadhall said:
Since you are so close I have a known good fuse box I could send down from a 97.
Any interest in trading? Ive got a set of disco rims, an extra 18" mondial. extra ABS pump, extra headlights and all the other lens's around the car. Ac controler, factory head and changer and sub. bunch of other stuff too. Obviously some things there I wouldnt trade straight across. I have an account with LR portland so ill have to see what my cost is on monday for a new one.

leftlanetruckin said:
Just drop either a new one, or a known good used one in there. Shoot Scotty a PM, I believe he had one.
Also check the voltage on your TPS, they are known to play havoc with tranny's on every other vehicle...

Martin
I am fairly confident that ill figure it out what ever it is. I would think since I have a known issue with my fuse block that its prob. the culprit, never know with these cars though.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
865 Posts
Could be any car not just Rangies, you wanna try BMWs when they start giving grief.....worst in the world when it comes electrical gremlins apart from being absolute rubbish after say 3 years.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #9
10
viperover said:
Could be any car not just Rangies, you wanna try BMWs when they start giving grief.....worst in the world when it comes electrical gremlins apart from being absolute rubbish after say 3 years.
Copy that, some of these euro cars i swear the egineer's who built them ride a bicycle to work, I bought my wife a "94 530i wagon, alpine white and in awesome shape, projector headlights and a set of stagered bmw wheels (pic below) I had to replace the quibo on that car when I got it, WTF? who names a part a quibo, better even, who puts a rubber disk between the tranny and driveline? not to mention all the rusted flange bolts that got broke from changing it. heres to a smooth shift :cheers:

 

·
Registered
Joined
·
344 Posts
I am in need of an ABS pump and have a brand new fusebox for a gems engine. anyone out there wanna trade something? :) i saw this post. i also have a ton of parts, so whatever one needs I can probably help with.
 
1 - 10 of 10 Posts
Top