RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
1988 SWB

A while back my tranny was performing less than awesome with 280K miles on it, so it was replaced with a lower mileage transmission.
The transmission shifts great between the gears while driving, although, some of the shift points are a bit off, but I'm having trouble with the actual gear shifter feeling like it gets stuck or doesn't want to shift into Park or Reverse. I have to shift back and forth several times before it will shift into the appropriate place. There feels like quite a bit of resistance or play and I'm not sure if it might be a cable issue, different shifter issue, or what.

Anyone run into this before? Thoughts on solutions?

Thanks in advance
 

·
Registered
1995-2002 Range Rover Classic
Joined
·
1,413 Posts
there is a bracket which bolts the shifter sheath to a mount bracket, those come loose or go missing thus causing your concern. check cable adjustment as well.
 

·
Registered
Joined
·
330 Posts
Shifter cable could use a good cleaning. Mine used to be a work out but after I cleaned & lubed it's like butter.
Also, remove the surround & make sure nothing is obstructing the shifter
 

·
Registered
Joined
·
17 Posts
Discussion Starter #4
Awesome, didn't know about these things. I'll check into them, Thanks!

How does one clean said shifter cable?
 

·
Registered
Joined
·
330 Posts
I had a spare. Pulled the inner cable out. Sprayed brake cleaner through the housing. Reinserted cable a few more times to free up any stubborn bits & sprayed again. Then lubed & reassembled.

It was going into the shop for something else so I had them do the swap. Better than lying on my back in the driveway.
 
1 - 5 of 5 Posts
Top