RangeRovers.net Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
good day gents;
My name is george i am from lebanon (middle east) and i have recently joined this forum to interact with the experienced owners of the p38 and gain knowledge in that event to make myself more involved in the repair and maintenance of my range.
i have just bought a p38,and i have been searching and reading posts and threads in this lovely forum for a while even before bying my p38 (so i am aware of most of its problems) i am posting a new thread now coz i didn't find out what i was looking for in this forum.

so gents this is my problem: when i shift from high to low everything works fine it engages very fast,but my problem is that i don't hear any audible message during the shift and no warning gear icon is displayed on the dash but the low selector flashes then it turns red upon completion.
i said to myself i can live with that,but when sun light is strong (covering the selector) i didn't notice that the indicator low shift didn't finish to turn into red and i put it into drive then p38 was not happy and even myself.
i am asking what seems to be my problem, why no warning icon?why no audible sounds?how to diy fix it ?
thanks 4 ur help.
 

·
Premium Member
2010-2012 Range Rover MkIII / L322
Joined
·
4,635 Posts
When shifting from hight to low ratio, there is no warning noise (except the sound of the motors on the transfer box). You should see the select neutral warning on the instrument pack information display though.
 

·
Registered
Joined
·
966 Posts
Rich998a said:
When shifting from hight to low ratio, there is no warning noise (except the sound of the motors on the transfer box). You should see the select neutral warning on the instrument pack information display though.

It should beep like 3 times, while the icon of the gear with the lines through it comes on the instrument panel.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #4
Jsmooth65 said:
Rich998a said:
When shifting from hight to low ratio, there is no warning noise (except the sound of the motors on the transfer box). You should see the select neutral warning on the instrument pack information display though.

It should beep like 3 times, while the icon of the gear with the lines through it comes on the instrument panel.
u are right that's y i knew that there was a problem,put what could it be?if there is a loose plug where the location might be?and if it is a dead lamp on the instrument,it doesn't have a backup one like for the brakes warning lamp?how can i fix that without the use of a test book? :think:
 

·
Administrator
Joined
·
27,794 Posts
THe lamp very well could be loose or burnt out, no biggie. THe lack of the warning beeps would be due to someone disconnecting the speaker on the back of the instrument pack. Do you have other warning sounds or even the annoying tick for the turn signals?
 

·
Registered
Joined
·
78 Posts
Discussion Starter #6
rrtoadhall said:
THe lamp very well could be loose or burnt out, no biggie. THe lack of the warning beeps would be due to someone disconnecting the speaker on the back of the instrument pack. Do you have other warning sounds or even the annoying tick for the turn signals?
yes sound is working,when key is ignition i hear the beep,and any warning on the instrument is heard upon display like (burn brake lamp,windows not set,etc...) turn signals make tick tick tick.i am wondering is there any plug available under the shifter or even under the car on the t box that may be loose? it is strange,no beep from shifting from high to low although the speaker is working.could it be because i have an airbag fault,and a low bat or even any burnt fuse?coz my bat needs replacing.any more ideas gents? :think:
 

·
Administrator
Joined
·
27,794 Posts
A dying battery or weak charging system can give result in all sorts of bizarre issues. Since you have to replace it anyway I would call that a first step.
 

·
Premium Member
Joined
·
1,703 Posts
hmmmmmm mine doesn't beep when shifting from low to high or vice versa, all the transmission gear selector lights flash while its changing and you hear a good thunk from underneath and the message centre display pops something up quickly and thats it. Maybe they changed it in the later cars?
 

·
Registered
Joined
·
78 Posts
Discussion Starter #10
jsp said:
hmmmmmm mine doesn't beep when shifting from low to high or vice versa, all the transmission gear selector lights flash while its changing and you hear a good thunk from underneath and the message centre display pops something up quickly and thats it. Maybe they changed it in the later cars?
well i am glad 2 hear that there is someone like me `) now i can rest
battery changed today i put 88 amps `) :lol:
now there is a list of pro oufff:
1.i think becm stays awake,i can c the dim light of the gear selector,although there is no radio interferance.
(even if i stay in the truck and sill lock it the dim light won't go off),is that normal also?
2.steering trembles heavily on 90 km/hr above that no trembling,is it the viscous coupling unit?or is it a different issue?i hope it simply needs wheels alignement.
3.my diversity radio is not displaying the ---- neither "code in" 8-0= i have the code but the lcd is frozed,just the screen light is on but nothing.
sorry gents with my questions,believe me i have searched the forum couldn't find wht i need for the radio,neither the becm.please any help would be very appreciated.thanks alot
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
865 Posts
Rich998a said:
When shifting from hight to low ratio, there is no warning noise (except the sound of the motors on the transfer box). You should see the select neutral warning on the instrument pack information display though.

Interesting, mine makes a low tone beep a few times until range change has completed.

I would say to remedy this problem I would connect a 12v pizo beeper onto the range change motor on the transfer box, you may need 2 as the voltage for the motor is reversed depending on range change direction but you will need to add diodes to prevent the pizo beeper from blowing, the wiring can easily be feed through where the gearbox/transfer box wiring goes through the tunnel.

I wonder if the Transfer box ECU has anything to do with the audible warning...Rave will answer that
 

·
Registered
Joined
·
78 Posts
Discussion Starter #12
my problems are solved :clap:
rebalanced wheels today and heavy vibration is bye bye.couldn't believe how an alignment is so important on a p38,on my bmw even if wheels are not properly aligned vibration was never so hard and strong. :clap:
as for the becm not sleeping,well it slept after 5 min of observation :clap:
when it comes to my diversity radio,well no luck the lcd is burned,electrician told me it is better if i install an aftermarket unit,so i am thinking of doing that even if i will loose the steering buttons,but i think i can still use the oem amplifier in the trunk with an aftermarket radio right?
 
1 - 12 of 12 Posts
Top