RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
hello gents;
i believe there is something wrong with my main fuse box in the engine bay.when i opened the fuse box cover i noticed there is a plastic burning smell,upon further inspection i have noticed that the main cable edge connected to the fuse box board that is coming from the battery has burning marks under it and arround it, i asked my mecanic about it he said to leave the fuse box as it is unless "i want to replace it he will replace it" :doh: he said that it is not hazardous nor dangerous,i asked for a second opinion at onother mecanic he said it better to be changed,so now i am confused,2 days ago while night driving i gi the following message:

fuse 12 failed,fuse 13 failed,fuse 14 failed,fuse 15 failed,my passenger light went off,then when i reached home,checked the mentioned fuses they were fine,turned off the car than on,then everything back to normal :think:

Then sometimes when the engine is warm and i want to start it it won't start from the first time but the second time ok.is what i am getting related to the fuse box?
fuse box must be replaced?wht is causing the main battery cable connected to it to melt the board down?is it normal?
plugged the test book no faults stored and all is normal.

thanks alot
 

·
Registered
Joined
·
541 Posts
If your battery connections all look good, I'd just go ahead and start looking for another fuse box. Just a hunch that it's going to continue to act up and if you have visible signs of distress then personally I would move forward with replacement.
 

·
Premium Member
Joined
·
1,703 Posts
repairing it is just a bandaid and might buy you 6 months time to save for a new one.
 
1 - 5 of 5 Posts
Top