RangeRovers.net Forum banner

1 - 20 of 47 Posts

·
Registered
Joined
·
300 Posts
Discussion Starter #1
the fuse to my steering wheel column and driver side power seat has blown out twice in a matter of 2 months, anyone know why it keeps going bad? :x

TIA
 

·
Administrator
Joined
·
27,819 Posts
I would guess you have a short. :think:
Have you checked for a pinched wire or failing component?
 

·
Registered
Joined
·
293 Posts
hey dude!!!! i just got the same problem!!! except my fuse didnt blow, the column and seat just stopped working i checked fuse 20 since its for both but the fuse was intact, did you find anything out???
 

·
Registered
Joined
·
300 Posts
Discussion Starter #4
gw2doc said:
hey dude!!!! i just got the same problem!!! except my fuse didnt blow, the column and seat just stopped working i checked fuse 20 since its for both but the fuse was intact, did you find anything out???

fuse just blew again, i think there is a pinched wire in the steering column :x
 

·
Registered
Joined
·
300 Posts
Discussion Starter #7
brad s1 said:
Mine does this too, I'll check the seat switch unplugged remedy tomorrow.
let me know what you find.. :thumb:
 

·
Registered
Joined
·
2,475 Posts
Its 20F outside right now, but I'm loading up the rave CD to see the access point and I'll be reporting back hopefully tonight
 

·
Registered
Joined
·
293 Posts
ill be checking under my seat tonight too, if i dont report back tonight i will report back tomorrow with the findings or lack thereof
 

·
Registered
Joined
·
293 Posts
im no so sure about the seat needing to come out... yet. Does anyone out there know which page it ACTUALLY shows on the rave manual how to take the seat control panel off the seat? my rave CD shows some manual recline lever for the seat and that there are four screws just sitting out there waving at you, pure fiction. Ive found the screw in the back and then it looks like there are just plastic tabs holding it on from there, but there is something towards the front holding it on and i didnt want to just yank on it, we all know how high quality the plastic on these RRs are...

and also that black plastic box which feeds the levers for the seat controls, does this need to come out with it? i think this might be the part with the pinched wire...
 

·
Registered
Joined
·
2,475 Posts
Yeah I'm sure you can do it with the seat still in there.. the issue for me is even though I have the rave cd and its telling me 4 screws hold it on, I don't see those screws anywhere... Feels like they're on the back side under the seat, how the heck do you access that?

Kinda annoying huh?

I'm heading outside in a few to keep plugging away on this... I'd love to have my power seat and steering back
 

·
Registered
Joined
·
293 Posts
yah me too, my seat is all the way up and the steering wheel all the way tucked...


when looking under it looks like there are just platic tabs connecting the panel to the black "harness"? you can disconnect those with a long flathead but two questions...

whats holding it on in the front, and does the "harness" that its clipped too have to come out with it???
 

·
Registered
Joined
·
2,475 Posts
Ok got it, there is a screw on the back.. Then the 4 tabs on the bottom, I un-clipped those and got it off, although some snapped, I may need to order a new switch panel cover (any idea where to get that?)... everything appears to be plugged in proper, it was too cold to pull all the plugs out and check them... Will report back when my fingers thaw out.
 

·
Registered
Joined
·
2,475 Posts
Ok I unplugged everything, zapped it with a bit of rubbing alcohol plugged it all back in, the seat and steering wheel are working now!!!!


Were have our remedy, I've been waiting over a year for this info :thumb:
 

·
Registered
Joined
·
2,475 Posts
****! I put it back together and it doesn't work again... I take it apart it works... Something must be loose inside the unit. :twisted:
 

·
Registered
Joined
·
2,475 Posts
Ok traced the short back to the lumbar support motor... It's too **** cold to pull the seat out today, I just put it all back together minus plugging in the harness for the lumbar control switch, put it all back together and have all the essential power seat movements so I'm 100% happy, the lumbar and bolsters are fine where they are anyway...


I suggest just pulling that one harness and seeing what happens.
 

·
Registered
Joined
·
293 Posts
when you say you "traced the short" did you find a couple of stripped or cut wires? or something else? were you just plugging in and unplugging each connection until you got it working?

what was holding the seat control panel on so tightly on the steering wheel end towards the top???
 

·
Registered
Joined
·
293 Posts
which harness was the lumbar support? can you snap a photo of the seat control panel off? id really like to see the inside portion of the panel to see where your disconnecting...
 

·
Registered
Joined
·
2,475 Posts
I traced it by having one thing plugged it, testing its full range of motion if it worked I'd pull the fused and plug something else in, lumbar popped the fuse so I pulled it, popped in another fuse and it all worked... But something is totally screwed here... Because it was working, then quit again. I noticed getting in and out of the seat fouls something, if you so much as touch the two wires coming down from the backrest section of the the fuse pops... Plus my steering wheel has completely stopped functioning.

I'm thinking the constant stress of getting in and out of the range pulls those wires from their respective connection points. (from somewhere up in the backrest of the seat) I bet if you pulled the seat apart those wires would be in need of repair and the cause of the short.

Let me know what you find, perhaps you just have a loose plug... Looks like my issues is a little more involved.
 
1 - 20 of 47 Posts
Top