RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
195 Posts
Discussion Starter #1
I have the coil and spring conversion done and the "FUSE 10 FAILURE EAS MANUAL" will come on every time I start the car, FUSE 10 if that's the fuse on the bottom side of the front pass. seat is OK and NOT blown, so I don't know how to stop that. Also, occasionally when I start the car, the red light indicating the ride height(on the center console) always changes, sometimes to LOADING, NORMAL, HIGHWAY, sometimes (2) lights will be on together like LOADING and HIGHWAY, sometimes NO light will be on at all and SOMETIMES the red light will be at the OFF-ROAD light which then triggers the dash with the yellow dash light indicating my car is raised with the arrow up. The previous owner always had all the electrical converted, so:

1. How do I get rid of the FUSE 10 FAILURE

2. How do I prevent the red light to go to the OFF-ROAD level which then gives me a dash light
 

·
Registered
Joined
·
195 Posts
Discussion Starter #3
Re: FUSE 10 FAILURE EAS and occasional ride height arrow light??

well im giving up on the FUSE 10 issue since that seems like a headache, but how do I disconnect those ride leveling lights
 

·
SUPER MODERATOR
Joined
·
27,758 Posts
Re: FUSE 10 FAILURE EAS and occasional ride height arrow light??

JaguarS4R said:
well im giving up on the FUSE 10 issue since that seems like a headache, but how do I disconnect those ride leveling lights
Pull the plug on the back of them.
 

·
Registered
Joined
·
195 Posts
Discussion Starter #5
Re: FUSE 10 FAILURE EAS and occasional ride height arrow light??

i dont care about those lights, but whenever the light happens to be in the HIGHEST OFF-ROAD RANGE, thats when I get the yellow arrow pointing up on the dash, its a hit or miss when I start the car. Each time I start the car, its somthing different with the ride height red dots and whenever it lands on the top one, thats when I get the yellow dash light. Thats what im trying to avoid
 

·
Registered
Joined
·
553 Posts
Re: FUSE 10 FAILURE EAS and occasional ride height arrow light??

I got excited when I read about Fuse 10 I still have the same message will try get to the bottom of it this weekend
 

·
Registered
Joined
·
553 Posts
Re: FUSE 10 FAILURE EAS and occasional ride height arrow light??

Solve the fuse 10 error by changing the top layer in my BECM
 
1 - 7 of 7 Posts
Top