RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
5 Posts
Discussion Starter #1
Full tank only shows 3/4 after remote sender & fuel pump rep

I have access to a T4 with the correct CD's for my 2003 Range Rover BMW 4.4L. I am the owner of the truck and spent an hour today with the T4 system trying to find the area where you "recalibrate the fuel senders/gauge/instrument pack" Does anyone with T4 knowledge know where this operation is buried in the T4 system? I have tried to google it for a few days an have found nothing but an old TSB on the the exact issue I'm having, but it has no instructions on how to do it in the T4.
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
5 Posts
Discussion Starter #2
Re: Full tank only shows 3/4 after remote sender & fuel pump

I Would like to know this as well, as I have an old 2003 RR HSE doing the exact same thing, and no luck on finding instructions how to reset it after replacing both sender unit for left side and pump and sender for right.
 

·
Registered
2016 L405 Full Size
Joined
·
20 Posts
Re: Full tank only shows 3/4 after remote sender & fuel pump

I would like to know as well. I just replaced my fuel pump assembly (both sides). I have also a full tank of gas, but the fuel gauge light is "on" reading no gas.
 

·
Registered
Joined
·
1 Posts
Re: Full tank only shows 3/4 after remote sender & fuel pump

Same issue here. two different units (from same source - ebay) behaved the same. Where did you get your fuel pump and sending unit? Manufacturer?
 
1 - 4 of 4 Posts
Top