RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
173 Posts
Discussion Starter #1
Just finished replacing the viscous coupling in my Range Rover classic. I installed the front output flange with the big nut. Torqued that down to specified torque (a lot!). Installed the front prop shaft and noticed some movement in the shaft when I grab the end closest to the viscous coupling housing and move it up and down, there is some play in it. It is not in the u-joints. I replaced the front output shaft bearing and seal. Is any amount of movement in that location acceptable? Want to know before I take the shaft off and investigate further. Can't remember if it had the movement before I did the work.

Thanks
 

·
Registered
1970-1995 Range Rover Classic
Joined
·
372 Posts
Movement in the slip yoke? There shouldn't really be any movement in the DS... being that your viscous seized... perhaps it caused issues with the DS? Paul grant likely has one for you if you need a stock one.

If there is movement in the output flange, id suspect a leak is in your future =/
 

·
Registered
Joined
·
173 Posts
Discussion Starter #3
Where I see the movement is at the flange. It could be anywhere from the flange to the inner bearing where the back of the VC attaches to the transfer box. I'll probably take the prop shaft off again and investigate further.

My 98 Discovery has the same movement with no issues.

Not sure what "DS" stands for.
 

·
Registered
1970-1995 Range Rover Classic
Joined
·
372 Posts
DS= drive shaft.

Flange would need a bit of tolerance in order to spin... if its too tight it would bind. If your disco has the same movement, and only leaks "normal" amounts then id assume good to go?
 

·
Registered
Joined
·
173 Posts
Discussion Starter #5
The movement is back and forth, side to side, not in rotation. Definitely not in the drive shaft.
 

·
Registered
1970-1995 Range Rover Classic
Joined
·
100 Posts
I found the same when rebuilding my BW box, apparently it is indeed normal according to Ashcrofts


Sent from my iPhone using Tapatalk
 
1 - 6 of 6 Posts
Top