RangeRovers.net Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Greetings - Ok...For my 2006 RRS HSE: Front amber parking lights are not on when switch is in parking light mode, or headlight mode. Rear parking (running) lights are operating just fine. I assume the front bulbs are good because the turn function works fine, as does the "flash" when you lock/unlock.

Thoughts, ideas, comments are all welcome.

Best,
 

·
LEGACY VENDOR
Joined
·
801 Posts
Are they dual filament bulbs?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
Good question - I don’t know. I too am curious that, and was hoping someone on here may know the answer.
Best
 

·
Registered
Joined
·
568 Posts
So lets see if I follow - in your country the parking lights and the turn indicator lights are in the one orange housing?

This is different to anywhere else in the world where the amber light is a turn indictor light only and the parking light is a "white" light in and separate section on the light housing.

So here is mine - the upper light is the orange turn indicator and the lower white light (an LED) is my parking light. From your description in your car both your indicator and parkers live in the orange housing if that is so then I cannot help - the lower white light in my lower housing is on its own circuit so easily checked.

IMG_20191020_175753

Garry
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
Hi Garry - Hope all is good. I appreciate your comments. You raise a good point...typically, and to my understanding both turn and park (front) are amber in the same housing. In the US, only 2 colors are legal for forward lighting assemblies. Amber and white, with amber being turn and park - typically. (Side comment—don’t get me started on the headlights that appear blue in color.....)

in reference to your photo - I don’t know what the lower white (yours LED) bulb is for??, and yes, I’m very curious as I haven’t seen mine operate and there is a bulb there.

I assumed, being the lower bulb is on a slight outward angle, they are part of the DSC forward lighting that adjusts to your turning, curves in the road....Am I totally off in my “assumption”??

Cheers
 

·
Registered
Joined
·
568 Posts
Ok - from you have said, it would seem the US is unique in the world in having parking lights and indicators in the one orange fitting - in most other areas it as mine are - orange is just turning and the lower is the white parkers and the cornering light sensor.

Ok I am not sure how your lights work bit will either be a twin filament globe (turn and parker) or it will be a single filament and controlled by an ECU ie - parkers are on and flash when turning etc.

So first you need to check fuses - first the engine fuse box to see if there is a dedicated line (unlikely) then check the fuses in the cabin behind the glovebox - there will be a line there. If OK time to check the globes.

So you need to take the globe out which is relatively straight forward from the back of the light housing. Check the globe if single filament or double and check they work - if they work then you need to check power is getting to the connector.

If you still draw a blank then maybe it is time for professional help.

So what is in the lower clear spot in US cars?

Cheers

Garry
 

·
Registered
Joined
·
30 Posts
Discussion Starter #7
Thanks Garry - good stuff.

As to your question, “What is in the lower clear spot in US cars?” — mine has a small bulb there....

Best
 

·
Registered
Joined
·
30 Posts
Discussion Starter #8
So - Can I call out to others, here in the US, that have an 06-09 Sport, and ask you to step outside, or maybe into your garage, crank up your Sport, and then turn on your parking / running lights and report back which front bulbs are illuminated? Maybe even snap a pic —

If you do this in your garage, open the garage door, we don’t need anyone passing out from exhaust fumes.
I appreciate the help with this.

Best
 

·
Registered
Joined
·
30 Posts
Discussion Starter #11
Thanks Phil — I really appreciate your taking the time for this.

So....maybe my bulbs are fried on each front corner. Guess I gotta fire up the YouTube and follow instructions on how to remove headlamp assembly.

I must admit, I’m surprised the front parking lights are white!!
 

·
Registered
Joined
·
568 Posts
:):):):):):) (y) 🆒

Check globes and fuse - as both are not working is possibly fuses but there are two. Interior fuse box Fuse 2 RH side lamps and Fuse 4 LH side lamps (my diesel so may be different to your V8). Once you remove the headlamp housing, access to the parking lights is under the removed housing.

Garry
 

·
Registered
Joined
·
30 Posts
Discussion Starter #13
...And God said, “Let there be light.” Then there was light....and the light was good.....

So finally took the time to remove the grill (watched YouTube video) and both headlamp assemblies - My front marker light bulbs (For Garry - Globes) were bad, also the small bulbs that illuminate the vertical amber section of the assembly were bad — I now have fully functioning forward lighting, and I’m happy.

Thanks Garry and Phil —
 
1 - 14 of 14 Posts
Top