RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
31 Posts
Discussion Starter #1
Hi there.

After having read a lot of good tips on this forum, I do not seem to find the cure for my cars problems, so here goes.

Status of EAS system:
-Two year old Arnott gen II springs all round
-Newly rebuilt valve block with parts from Shupack, incl the diaphragm
-NRV tips in VB are worn, but reading the forum, most appear to be...
-Rest of o-rings in the EAS exchanged
-New uprated/high capacity Thompson compressor
-Soldered the connections at the LH A-post. Copper in some wires were black, but I assume the soldering was ok still.
-Checked the connector going into the EAS-CPU. All gaps on the female contacts appeared to be of the same widths, so I take these are ok (an other possible culprit according to member’s experiences)
-Tried an old drive pack with unknown status lying around. Exact same symptoms, but both packs could of course have the same fault...
-Compressor runs a lot and gets really warm. Runs erratic. Any thing from burst of 2-3 seconds up to long continuous runs.
-If the car is raised to a desired level (normal) and the EAS relay I pulled, the car will stay in that height for 7 days +, whether its left standing or driven.. So no leaks in the solenoids controlling each corner and out to the bags I presume..
-Height sensors are probably from the build year.
-The car is not leaning to one side at any point of time (at least not noticeably)

Symptoms:
-When I start driving the car in the morning (with the EAS relay attached), the car drops to the bump stops up front within a minute or so. Rear height is fine. Compressor will be running
-It will stay down if left.
-The front can be "picked up" by flicking the level switch down to highway mode and up again. Same result if I wait for the rear to drop or click it up again instantly.
-As mentioned above, driven around with the EAS relay out it is stable and fine. No compressor running.


Has any one experienced this behaviour and most importantly, have a tip or two??
 

·
FOUNDING MEMBER
Joined
·
4,509 Posts
that sounds like a sensor or calibration issue, especially since it comes back up when you "remind" it how to operate. check the height readings on the UNLOCK program when it drops and compare to before/after.
 

·
FOUNDING MEMBER
Joined
·
4,509 Posts
Ottar said:
But irratic running of compressor, is that due to bad calibration?
could be, if it's constantly going up and down, the compressor will have to refill the tank after every "up" cycle, then stop to go down.
 
1 - 4 of 4 Posts
Top