RangeRovers.net Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
349 Posts
Discussion Starter #1
....which was eminating from behind my center console any time a door was opened. Now, what the heck is this little bugger? One of the HVAC flap motors I assume? This is on the passenger's side.

 

·
Registered
Joined
·
349 Posts
Discussion Starter #3
No idea..I just unplugged it and so far, several months later, no harm no foul.
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
13 Posts
I've got this noise and have isolated this motor and freed the flap but it has not stopped the noise which is driving me nuts
 

·
Administrator
Joined
·
27,822 Posts
If your gears are worn from"ratcheting" for so long, you will need to replace the motor.
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
13 Posts
Thanks, I don't want to appear really dim but I did see the motor actually move when uninstalled but still connected. I also still had the noise when I disconnected the (two wire) connection to the motor but left the motor installed. This noise, like a cicada on steroids, surely I can't have the only RR in the world that has this problem??
 

·
Administrator
Joined
·
27,822 Posts
If the motor moves when removed then your flap is sticking. if you still have the sound with that motor disconnected, you must have another flap stuck and motor skipping.
 

·
Administrator
Joined
·
27,822 Posts
Down load RAVE, factory workshop manual. link is in the FAQ stickie above
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
1,208 Posts
They are all right around the on you have a picture of. Think there are 5 of them in a low line system, 6 in the high line. All of them are different part numbers. The one in your picture I beleive is on the passenger side and it feeds the rear vents in the back of the center console. There are 2 additional ones above and forward of that one on the passenger side, and an additional 2 on the opposite side.
 
1 - 11 of 11 Posts
Top