Range Rovers Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
1,747 Posts
Discussion Starter · #1 ·
A few days ago my radio stopped producing any FM stations, and as it seems even receiving any FM stations at all.
The AM, navigation and CDs work fine, so it seems everything else is working.
That led me to the antenna circuit as the first thing I suspect.
Looking at RAVE, the best I can tell is that there is an amp (pictured) between the antenna (back window heater element), and I looked at the 3 wires going to it.
There's a red with a black stripe,and white with yellow stripe, and a white.
I can't find much info in RAVE for the wires to or from the antenna amp, but as far as I can find, the white wire is power.
Does anyone know or is able to find where the wires to and from the FM amp connect?

At the white wire read about 0.6 volts, but not sure since I can't find what the return line is.
If you can tell what the return line is and what the supply voltage is, it could help me figure out if the amp is bad or not.

Has anyone got any suggestions or experience with FM-only radio problems?

Thanks for the help!
 

Attachments

· Registered
Joined
·
1,747 Posts
Discussion Starter · #2 ·
For future reference, apparently this is not the FM radio aerial amp, but is the RF receiver for the key fob.
I found info in the RAVE to tell me that, but still nothing to help me find why my radio has lost FM reception.
If anyone has any suggestions, they will be very welcomed, but until then... onward.
 

· Registered
Joined
·
1,807 Posts
Have you tried disconnecting the antenna lead and connecting a long wire to the center pin on the plug?... in theory that should get you pretty good reception if you're tuned to a station that normally has strong reception. If that doesn't work then you know the tuner is probably no good (make sure your wire is actually touching the center pin though!).

If you get a signal, then you probably an an issue with the wiring or the antenna amp.
 

· Registered
Joined
·
1,747 Posts
Discussion Starter · #4 ·
Hi Linux. I haven't tried that, thanks for the suggestion.
I was considering doing that sort of, basically bypassing what I thought was the FM amp, but unless it does double duty as the receiver for the remote key fob, it isn't. But then again, maybe it is?
I'm not sure which amp is the FM antenna amp, or even where it connects. The RAVE schematics are kind of sparse on the audio system.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top