RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1
Last weekend I put new tie rod ends on my rover which turned out to be a cake walk. At that time I ordered a steering damper and a new flex coupling for the steering shaft. It seems that the auto-parts sent me the wrong parts as the coupling is metal. Then I thought I seen somewhere that they did away with the flex coupling so maybe the metal is the right part? With the steering damper they sent one with a post mount on one end and a loop mount on the other. So yeah, guess I have to put up with the death wobble a bit longer.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #4
Heh, the auto parts came from the one that is listed on this site, Auto Parts Warehouse. I suppose anyone can make a mistake so I won't discredit them yet although I have been waiting for an RMA number longer than I should. If they don't get me one by Monday I will call them again. I want to be able to drive the Rover to Philly next weekend.

The flex coupler is the one on the upper part of the steering shaft. The one that typically gets cracks in it and the steel one they sent me looks like the plastic one.

I should be able to install it this weekend and we will go from there.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #5
Well, right now I feel kinda stupid....

When I stated that the part they sent me was all metal. I was assuming it was because it sounded like metal when hit against something while still inside the bag. Though, once I took it out of the baggie I found to be rubber with steel inserts just like the OEM part.

So yeah, I did install it and though it was a pain in my bottom it's done. Now just to wait for an RMA number so I can get a damper that fits. No. I know, I already double and triple checked it out.
 
1 - 5 of 5 Posts
Top