RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
hey guys, was wondering if anyone could shed some light on a problem encountered ?

I swapped my stock 03 bmw style mirrors with puddle lumps & power fold for the later style 2005 larger ones (picked up on e-bay -always liked the the larger viewing range)

The connectors are identical & went straight in & although the wiring colours are not the same everything seems to work fine, puddle lights, adjustment memory etc except power fold. When the button is pressed the mirrors start to move inwards but about a 1/4 of the way in they then return out .
the mirrors don't seem to know their position?
I got hold of the wiring diagrams for my 03 cars & the only difference is a microswitch situated on the mirror body which i assume has been done away with on the later mirrors..
what baffles me is that i have seen late my 04 ( pre facelift but with touchscreen nav ) cars wearing these mirrors?
any ideas?
 

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
560 Posts
I think if you do a search on the forums this has been a problem even with the original mirrors having the same issue. I believe there is a sequence to reset the mirrors so they fold in again.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Thanks for your posts guys, but my prob is that the new style mirrors don't have the microswitch inside & Ican't figure out how the new mirrors get their open & closed position info. any guesses?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
mirrors now working. & folding in/out. Had to upgrade the mirror control modules to 05> ( driver & passenger front window switch assembly) to get powerfold to work properly but luckily got them from a really reasonable guy on e-bay.
 
1 - 5 of 5 Posts
Top