RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter #1
So I just finished uploading the video of what happened and them fixing it at the dealership.

Here is the short version for those who don't care to watch it.

I drove my RRS into a pretty deep body of water, at all times I was below the max wading depth.

Got stuck! YAY!

Was in there for about 10mins (destroyed my rims) lol

2-3 weeks later the starter started to fail.

Being in Mexico, things are a bit well, Mexican (overly complicated and as inefficient as possible). The dealership had to order the part from the UK, even though 2 hours north in Texas they had one sitting on the self. In order for the warranty to cover this, the dealer had to order it directly from the UK, I also wasn't able to get authorization to buy it from the dealership in Texas and just bring it down to Mexico either, they did make an effort to try to get that to work though, so I was appreciative of that.

LR MX ordering from the UK office takes 15 days to get the part, add the holidays in there and boom, a month with no Range.

All in all, they covered everything, hotels, rentals, tows etc. I was beyond impressed with their customer service and how they took care of me.

Couldn't be happier with the brand.
 

·
Registered
Joined
·
73 Posts
Nice! Just watched your video- pretty cool that they came through for you. That dealership actually looks nicer than a lot of the dealers you see in the US!
 
1 - 3 of 3 Posts
Top