RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi, my 06 RR Sport HSE just started idling rough and the dash is displaying every fault possible. The display shows “Engine System Fault” “HDC Fault”. claims the air suspension has a fault. Battery light is on even though the alternator is charging at 13.6v, traction control and ABS light is on. Car is in limp mode and will only go about 2 mph. This happened out of the blue one morning when I started it after parking in the garage overnight. I found some threads that referred back to the brakelight switch so I replaced that. Reset the ECU by disconnecting the battery, finally sent it to the dealer for diagnosis. They come up with possible bad ECM and replace for $2500 but they’re not sure. That’s an expensive troubleshooting tool. I’m a Porsche mechanic, and have been for decades. I can count the number of bad ECMs I’ve encountered on one hand. Anybody else encounter this sort of problem?
Thanks
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
Oh yeah, new battery and alternator less than 3 months ago and I had the dealer double check the battery when they were doing a diagnosis.
 

·
Registered
Joined
·
26 Posts
I have heard that new battery story from the dealer! please meter the battery without anything turned on. The problem could be from the battery if it is below 12.5 or 12.6 volts. All 13.6 means is that the alternator is doing the job but it doesn't mean the battery is good. I would even go one step further and have a shop test the battery professionally and give you a report. Also hope you didn't place non OEM battery in this car.
 

·
Registered
Joined
·
26 Posts
Have the dealer give you the battery report. I had this fiasco with Land Rover Canada. I kept saying the problem is the battery and they said the battery has tested fine. Long story short, after the car was towed to them 3 times they said even though the battery has tested fine, out of the goodness of our heart we have decided to change the battery! All my problems were gone after they replaced the battery.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
I’m getting it back this week. They should be providing all of the diagnostic info, and I’ll definitely double check the battery. It is aftermarket but it is also pretty much brand new. Thanks all.
 
1 - 6 of 6 Posts
Top