RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
2006-2009 Range Rover Classic
Joined
·
2 Posts
Discussion Starter #1
2007 SC RR with 85 K
Last week it rained. Radio / Nav did would not go on, light blinking continuously , screen stuck on "Land Rover" logo.Was planning to go visit the dealer tomorrow. Now I go to start my white angel and she wont turn over! Battery is fine. The parking brake light indicator (red on dash) stays on, and the parking brake feels like its engaged- when I go to press my brake in when I attempt to start car its firm. Have tried both keys, nothing. Engine wont turn.
Have attempted to disengage parking brake - nothing... Any suggestions? Is my white angel having an electrical temper tantrum? Any help would be appreciated
 

·
Premium Member
Joined
·
2,467 Posts
How are you determining that the battery is fine?

There may be a small rocker switch in the panel that sits above the drivers seat, right in the middle. With the key turned on, see if pressing that changes anything.
 

·
FOUNDING MEMBER
Joined
·
938 Posts
Welcome to the forum Flurry!!!
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
26 Posts
Flurry,

I'm experiencing the same issue with my '07 RR SC with 61k miles. She drove fine until I had it sitting in my garage for about 10 minutes listening to a radio with the engine off. Engine tries to turn over but does not and while doing so, I see a red blinking PARK light on a dash cluster.

Did you find out what caused your vehicle to not turn over?


Thanks,
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
26 Posts
Luckily, the engine fired up after trying again in about 30 mins or so. I'm glad it was nothing serious, well, for now.
 
1 - 5 of 5 Posts
Top