RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello everyone. Recently bought a 2007 RR Sport HSE with 98k miles. I just noticed a loose connection with nowhere to plug it into. I’ve searched and searched but can’t find out where this loose connector goes to. All the lights, turn signals, and fog lights are functioning. Looked at some online schematics and all I could come up with is that maybe it’s The brake boost relay? However, I don’t see any female connector to plug it into anywhere in the vicinity of where it’s dangling from. Maybe it was run through incorrectly during a prior repair and should go underneath the radiator core? I’m really confused. It’s in the engine compartment by the radiator reservoir tank. It’s green & white wires with a grey 2 pin connector with yellow at the end. I have a yellow suspension fault, yellow triangle with a circle, and a yellow brake light coming on, but I have a spare on it right now. It runs great. I’m just waiting to get the faults cleared. Hopefully. We all know how that goes. I just really want to know where this plugs into. Any help from the RR community would be greatly appreciated.
 

Attachments

·
Registered
Joined
·
553 Posts
The same basic wiring looms are used for all the different models so is most likely a connector that is used in another spec vehicle or even an different engine type.

I do recall that there is a plug in that area that was used at the assembly and is related to initial battery installation but I cannot recall specifics and may be right off mark.

Every thing works, if something was unplugged there would be another plug nearby which there is not, so don't go looking for issues that are not there - if you have issues well that is different.

On those faults - try a hard reset of the of the systems and see if the faults go - if they come back then get the codes read which will point you in the right direction. The faults you have will not have anything to with the spare connector.

Go an enjoy your car :).

Garry
 

·
Registered
Joined
·
553 Posts
Was just looking at another RRS forum and on there was a question where is switched 12v in the engine bay - now this was for a RHD diesel but the response was that there was a spare 12v switched connector behind the grill - near where your connector is - so see if it is switched 12v and there is your answer - is there to connect "an accessory" under in the engine bay that needs switched 12v.

On my RHD diesel I have two spare connectors in the same general position as yours but they are plugged into blank plugs attached to the body work with press studs. Maybe yours is similar and the blank receptical is missing.

Garry
 
1 - 4 of 4 Posts
Top