Range Rovers Forum banner
1 - 3 of 3 Posts

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
77 Posts
Consider me subscribed. Having the exact same issue with my 2011 RR S/C. It is the onle thing on my 2011 thats doesn't work. Everything else is tip top. Do any lights illuminate on your dash? Mine makes zero noise and no lights. Also, I checked the fuse in the rear boot and it was fine. I beleive it was in spot number 6.

Hello i am looking for info on how to repair the EPB unit on a full sized 2010 Range Rover.
It looks like the gears have sheared.

So far the only option i have found is to buy a new control unit, about 1100.00 dollars
And it appears that the exhaust and the rear sub frame must be moved to reach this box
Part number of the EPB is LR028112.
do the repair kits for the Range Rover sport also fit the Range Rover full sized unit,
as a set of new gears is 60.00 for the sport gears but no joy on a repair kit for the FFRR
Thanks Stan
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
77 Posts
So I read thru the entire post from 4x4 and it was very entertaining. The guy is smart and funny. In the end I wonder if mine is more simple as I stated before I receive no warning lights or any of the indicators he dealt with. If it were a pre-2010 I might think the previous owner removed the bulbs behind the instrument cluster to keep them from annoying. Its not though as its a 2011 and has the TFT screen which clearly means thats not why there are no warning lights. Guess Im off to the repair shop to see if the module can be communicated with.
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
77 Posts
what are your symptoms?

I am in thew process of ordering all of the parts to do a swap
New EPB unit
New rotors,
New pads,
New E brake shoes,
and spring kit.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top