RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi to you all.
Love my 2011 L322 Range Rover Supercharged , but the other day i was driving home and it died on me.
It comes up with lots of : lost communication faults but still has power to open the doors and radio for example. However it will not start the engine . Can anybody please help me. Regards Jake.
 

·
Registered
Joined
·
234 Posts
Start from the beginning and have the battery load tested.

L322's are especially reliant on a perfect battery.

Rob
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Start from the beginning and have the battery load tested.

L322's are especially reliant on a perfect battery.

Rob
Hello Rob.
Thanks for your help , i will try that first but it is only a two week old battery. If that is not it what else would you suggest please.
 

·
Registered
Joined
·
234 Posts
If the battery was just replaced, double check the tightness of the battery terminals. A loose terminal may give you the same fault.

You’ll need a 13 MM wrench for the +ve and a 10mm wrench for the -ve.

Rob
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
If the battery was just replaced, double check the tightness of the battery terminals. A loose terminal may give you the same fault.

You’ll need a 13 MM wrench for the +ve and a 10mm wrench for the -ve.

Rob
Hey Rob.
Thanks again for your help , that will be the next thing i check.
Wish me luck.
Regards Jason
 

·
Registered
Joined
·
11 Posts
Jake

If the battery is only 2 weeks old and the terminals are tight etc then the next port of call will be to check the output from the alternator. Either charge the battery or use jump leads to start the car and put a voltmeter across the battery terminals. You should see a reading of around 14.5v. Anything much less than that and your alternator is goosed.

Good luck

Cheers, Mark
 
1 - 6 of 6 Posts
Top