RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
So this morning I was headed to the dealership to have my fuse changed for the power outlets and I noticed the screens went black when I started up the car so I mentioned it at the dealership. They said there was a new software update which should fix it. I drive home with the car and notice my phone is now not connecting via Bluetooth and that the satellite radio is stuck. The bottom screen keeps flashing when I open the front door before I start the car. Going to have to bring it back up there. I’m very disappointed. Hope I don’t have these issues indefinitely. Any one else having similar problems after new update?
 

·
Registered
2016-2018 Range Rover MkIV / L405
Joined
·
52 Posts
So this morning I was headed to the dealership to have my fuse changed for the power outlets and I noticed the screens went black when I started up the car so I mentioned it at the dealership. They said there was a new software update which should fix it. I drive home with the car and notice my phone is now not connecting via Bluetooth and that the satellite radio is stuck. The bottom screen keeps flashing when I open the front door before I start the car. Going to have to bring it back up there. I’m very disappointed. Hope I don’t have these issues indefinitely. Any one else having similar problems after new update?
This thread may be enlightening.

http://www.rangerovers.net/forum/43-range-rover-sport-ii-l494/312129-2018-dual-monitor-issues.html
 

·
Registered
Joined
·
46 Posts
Discussion Starter #3
So this morning I was headed to the dealership to have my fuse changed for the power outlets and I noticed the screens went black when I started up the car so I mentioned it at the dealership. They said there was a new software update which should fix it. I drive home with the car and notice my phone is now not connecting via Bluetooth and that the satellite radio is stuck. The bottom screen keeps flashing when I open the front door before I start the car. Going to have to bring it back up there. I’m very disappointed. Hope I don’t have these issues indefinitely. Any one else having similar problems after new update?
This thread may be enlightening.

http://www.rangerovers.net/forum/43-range-rover-sport-ii-l494/312129-2018-dual-monitor-issues.html
Thanks just found it. I’m so upset over this.
 
1 - 3 of 3 Posts
Top