RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
1995-2002 Range Rover P38A
Joined
·
19 Posts
Discussion Starter #1
Have an issue with the height selector switch for eas in automatic mode it works perfectly, but when you select motorway setting it will drop to access mode even with the inhibit switch on!
Have any of you good people got any ideas, thanks.
 

·
Registered
1995-2002 Range Rover Classic
Joined
·
1,413 Posts
check your heights, also motorway is not user selectable. off road, city and access are selectable. motorway is automatic once above 50mph for over 3 minutes
 

·
Premium Member
Joined
·
1,321 Posts
Motorway IS user selectable, but only with the inhibit switch activated. Which leads me to suspect the inhibit switch. With it activated, will the Range lower to motorway height when doing over 50mph for a minute or so? It should do so only with the inhibit switch inactive. Maybe the signal isn't getting through to the EAS. Does the light work?
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
19 Posts
Discussion Starter #4
All the lights on the switch work, or do you mean the inhibit switch. will try your idea tomorrow on the way to work!
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
19 Posts
Discussion Starter #5
Tried the height selector switch today,and guess what it all works again as it should.
Starting to think none of the functions on this car were not used much during it's lifetime. maybe see if I can get some contact cleaner in the switches!
 
1 - 5 of 5 Posts
Top