RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I took out my '98 4.6 RR valve block and replaced all o-rings. It was leaking left and right, taking a while to come up after starting and loosing pressure over night. Hopefully this will get it fixed.

After re-installing the repaired valve block i continued to check its operation through jumping the connectors on EAS ECU C117 under LH seat, however, I haven't been successful in raising the RR on all four corners.

- The compressor works fine connecting pin 1 & 8 with no problems
- Pin 11 (LR) with 26 (inlet) & 9 (exhaust) is the only corner working properly.
- Pin 10 (LF) seems to raise both RF & RR. So far I can't control them both separately.
- FL wont budge although I can hear a solenoid clicking.

I am second guessing my numbering of the solenoids when I took them off the valve block, I may have put them back in the wrong order. Could this be the issue? If so, whats the right order for the solenoids?
Plus, I read that although they may look identical each is different in its internal components, which leads me to ask if there is a way to distinguish which solenoid goes on which corner? Aside to doing it through trial and error which could require take out the valve block a number of times and disconnecting the pipping each time.

If I take her to the dealer he will suggest changing the valve block, which is not an option at the time! So I would really appreciate some advice
 

·
Registered
Joined
·
922 Posts
1 - 3 of 3 Posts
Top