RangeRovers.net Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter #1
Sorry for not using search, but I am at defcon1......Mrs called, on the road.........said " Range Rover stuck on high , all four ride height lights on, can not be manually lowered, no message on message center except ride height indicator".........any thoughts???

Oh just got a call back....apparently she drove over a small curb at low speen in a parking lot yesterday { funny how this stuff come out}

Have no idea where to start with this , any help much appreciated.

Thanks,

Don Scott
 

·
Registered
Joined
·
107 Posts
Discussion Starter #3
update....Mrs went to store...shut off....when she restarted.. " normal"....went to get gas...shut off, " Normal" again on restart.....so... looks like this was a soft fault that cleared itself?? do they self heal??.....or do I have a bug thats going to bite me eventually??

Thanks,

DS
 

·
Registered
Joined
·
966 Posts
EASUnlock will read the logged fault. If it was a sensor out of range, it should go back to normal once the sensor has read a normal range.
 

·
FOUNDING MEMBER
Joined
·
4,509 Posts
going over a curb should NOT cause a sensor fault, unless the sensor is failing. Read/clear the codes and report back, we'll tell you where to go next.

and yes, soft-faults are self-clearing IF the problem goes away.
 

·
Registered
Joined
·
107 Posts
Discussion Starter #6
ALL GOOD through 5 cycles and 2 days....maybe I dodged a headache...maybe a clump f snow or somethimg..thanks all.

One last question on EAS , in the am...RR is down a little, not much....on start up the pump runs for maybe 20 seconds then shuts off...however it takes another 5 minutes for it to be at height and the flashu=ing light to go off....seems to me theyshort pump cycle indictaes that their is plenty of air in the system...however it seems to "hunt" and take a lot of time for the EAS to fiqure out what to do??

I have a valve block rebuild kit and other stuff to do when the weather breaks.

Best,

Don
 

·
Registered
Joined
·
269 Posts
i dont have a good solution for you...but do you know how many people would kill for their truck to "stick" on the high setting?
 

·
Registered
Joined
·
217 Posts
You can make your truck stay at whatever setting you want by pressing the inhibitor button on the dash and you can cruise in highway mode all the time if so desired. Engage the inhibitor and then pick your ride height and it will stay there till you tell it to move. :thumb: unless of course you select max hieght and try to go over 35 mph. My height freeks out every now and then when it's cold out and goes to max height and stays there till I shut it off and restart and then hit the highway and keep it above 50 mph for a mile and then it always clears and goes back to normal operation and so far every time I've run a diagnostic the only code it shows is ; vehicle has moved ; what the f##k that means, I don't know. Anyone know what that code means? Good luck, T.
 

·
Registered
Joined
·
121 Posts
I have ran over a curb on the old girl, she went into extended. and stayed there as well, It may have thought that it was high centered. It was fun getting out of it while in extended, then climbing back in... :)
 
1 - 10 of 10 Posts
Top