Range Rovers Forum banner

EAS-reset sync problem

6450 Views 16 Replies 4 Participants Last post by  Edable

I've bee trying this all day long. Double checked all the wiring a couple of times, is seems to be fine.

tried almost every possible combination of the delays. Also I've been trying this with two different serial ports - the one on the docking station of my thinkpad, and a USB/serial prolific dongle - both worked fine a lot of times with a lot of devices I'm working with.

Any advices what to look next. I can't wait for new cable, will have to make this one work.

this is what I get before the RX starts displaying 0,80,0,80 etc ...

I've checked almost every possible topic here and on the sourceforge forums too. I'm starting to think the OBD port of my RR is the problem :(

Any ideas ?
See less See more
1 - 10 of 17 Posts
yeah, today I'm going to check the obd on the car
Triple checked everything again, still nothing :(

Please help with any advises. I do reset the EAS with the initialize button (at least it seems so, every time the relay is clicking and the beeper beeps twice.

What else could be wrong ? Sometimes I receive 50s sometimes 54 .... not FFs at all ...
One more thing ? When the sync is lost, am I supposed to receive just "80"s ??? Becaus what I got is a sequence of 80,0,80,0 ... if that could be a clue to my problem ?

See less See more
I've just attached a regular PC with hardware builtin serial ports and still nothing different as a result. All I got is 0,80,0,80 sequence instead of FFs - I guess that eliminates the port settings and dongle as a suspect, also the PC and OS.

Checked the cable even when plugged in the car's OBD ... the wires do make contact when I test between the rear end ov the vehicles obd connector and the rs232

Could I be totally wrong in understanding the wiring, or do my Rover has some kind of strange problem ? It's a 2.5 DSE p38, '96 .. if that matters. Software version in the about menu is 2.0 (rangerover_easunlock_suite_win32_10-20-08.exe) and the cable schema I use is from the menu of the software.

There is one more thing - on the OBD connector I've used pins 4 and 5 where connected. I've tried both with the default connected state, and later I've cut the link between them.

I'm desperately willing to solve that problem, please help
sotal said:
The OBD connecter on my cable also has pins 4 and 5 connected together, I wasn't worried though as they are both grounds, one is signal ground and the other is chassis ground.

You've done what my next test was going to be, which is to plug the cable in and test continuity between the back of the obdII port in the car and the rs232.

I've no idea but the software writer is a member on here, you could try PMing him or waiting to see if he comes along to help!
yes he is, and he wrote me yesterday with some advices, but unfortunately none of them worked. Hopefully he will notice this thread later. Meanwhile I've found two other users having the same problems in the past, but none of them provided a solution or at least, not mentioned there - viewtopic.php?p=275016#p275016
As I wrote in the other thread, solution is as follows:

j1v said:
Kancler said:
i just figured out why i did get response with 3f not ff, problem was so easy and it was in front of me, but i was to dumb, but all my bright ideas comes in the morning, when im dieng from to much alkochol in yesterday party :D
so solution - im using Lithuanian regional seting, and u ppl using US regional seting, its . and , mater :D huray for me :D tonight im gona party for all hapy oweners with working eas system :D
10x for that man, after trying everything else, changing from bulgarian to english-us worked ...
Malafax_dand said:
And I have indeed heard of regional Windows settings interfearing with the comm port function. Although this has usually been from eastern countries.
I suppose it's got nothing to do with "interfearing"the comm port, most possibly somewhere in the source you're not using exactly "." or "," symbol, but "decimal symbol" as of windows, that is different in different country.

I suppose only changing of that in the regional settings would work and I'll give it a try, but that is still not a solution, the best way is to find that and fix it in the source. Or maybe at least add that problem to the FAQs on your website, I was about to surrender after trying almost everything for a couple of days.

Anyway, thank you for that great software, I finally have my car up and running.
Edable said:

From below I gather u finally sorted out the problem.Please can u give of how u made it to work in detail?

I ve disconnected the ECU and now use jumpers to pump up my balloons.
Like I said, the problem was the regional settings of Windows. When I switched from "Bulgarian" to "English, US" everything worked like a charm !
Edable said:

Sorry am a little out of tune,how do you change the regional settings of windows
start -> settings -> control panel -> regional settings :)
1 - 10 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.