RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi all,

I am looking for advice on a problem that I just located. I have a 2000 HSE 4.6 with 69K miles. While changing the pollen filters I hear a hissing sound coming out of my EAS unit(I was leaning over it). On investigation it turns out to be hose 6 and th hissing get louder when I push it in, lower when I pull at it. The hissing is barely audible otherwise. The car drops overnight but not to the bump stops once running, will rise and fall rather quickly. The whole EAS unit was replaced 4 months ago. Should I worry?
 

·
Registered
Joined
·
85 Posts
I am no expert but i have completly rebuilt my entire EAS system on my RR 4.0 with the help of this forum and Dennis and Rover renovations. It sounds like you need to trim the end of your hose and check the collet and o rings that seal the air hose. If you go to his site and email dennis, he will tell you what you need. He ships quick and he really know his stuff.

chris
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I have been on the site. I see from the site that air line 6 goes to the tank. How do I contact him?
 

·
Registered
Joined
·
85 Posts
www.roverrenovations.com

I to have a small leak from my tank somewhere. If you truck is going down overnight than it is not line # 6. I would recommend doing the valve block rebuild. You can do it yourself in a afternoon or Dennis can do it for you. It's like having a new EAS system.

Good luck... Chris
 

·
Registered
Joined
·
922 Posts
How do I contact him?
send him a personal email through this site or email him using the contact in the Rover Rennovations site ....
 
1 - 5 of 5 Posts
Top