Range Rovers Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 ·
Hi All,

The front of my 2000 4.6 will randomly raise up and then lower to the correct hieght, but it will do this every 2 to 5 minutes! Even while driving it does it!

When standing at trafic lights it will suddenly raise up the front, change over the solinoids and lower it back down. If standing for long in trafic it will do this randomly with from 30sec to 2 min intervals.

This makes the pump run almost non stop to keep up with this demand.

What is wrong? Is one of the sensors in front giving a bad reading so it raises it up and lowers down to a good reading or what?

I check the height reading while it does this but they don't go ouside the limit or apeer to jump. Perhaps the readings don't update quick enough to show a jumpy reading?

What to do?

Cheers,
CRV.
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #5 ·
Ok, lets put this in perspective.

I just installed ARNOTT GEN III's.
Bought an overhaul kit for the valveblock and pump from Dennis and installed.

It did this before the overhaul too.
It does not go down slowly as with a leak. I have checked for leaks too.

I can start it up and it will come up to the correct height.
I then just sit there watching the front against the background and make sure it does not go down.
Then it will just start lifting it up, and then lower to the same position it was at.
It will do this every 1 to 2 minutes.

So I susspect a sensor irratic reading?

If I open the door it does not do this so it should not be a leak.

CRV.
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #7 ·
Ok, some more investigation reveals that with all the spring valves closed and the air tank full if I open the exhaust valve nothing happens, but if if I open the inlet valve the right front corner slowly raises.

I did replace all orings in the valve block.

This means the right front bag valve leaks when applying pressure from the air tank only. If I close the inlet valve it will remain like that, no movement.
Does this meant the spring on the valve does not hold it closed with enough force? How do I fix this?

this causes the vehicle to constantly release pressure from this bag and cycles the pump to keep up.

CRV.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top