RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
1995-2002 Range Rover P38A
Joined
·
5 Posts
Discussion Starter #1
Hi all,
I have an issue with the drivers seat not moving. I have replaced the outstation with one from ebay, the BECM power board has been replaced along with the seat switches. I have power from the BECM to the Outstation and power from the switches to the Outstation, but it still wont budge. I have connected power directly to the seat motors and they will move.



Thanks in advance?

Mike
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
5 Posts
Discussion Starter #2
Ok, so I seem to have fixed this. After following all the wire diagrams I concluded that there must be something wrong with the Seat Enable wire. I had previously undertaken continuity checks on the wires and all were ok... however I started playing with the harness from the BECM to the outstation and suddenly I got some movement. If I push the connector on the harness from the BECM to the outstation then it works. So for now I have zip tied it :) I will replace the harness next summer but for now I can take the car back for an MOT re-test as it failed on the seat not moving.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
772 Posts
Clean the connectors properly, don’t think I’ve ever had a car fail on seat not moving, hardly a safety issue if you mot tester is taller/shorter than you, lol
 

·
Super Moderator
Joined
·
2,332 Posts
But it is part of the UK MoT test. It isn't that it won't move but they have to move the seat and ensure it locks into place and doesn't slide about while you are sitting in it. If it doesn't move then they can't check that it locks in different places. A sensible test on a car with manual seats but a bit pointless on one with electric seats I must admit.
 
1 - 4 of 4 Posts
Top