RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 2013 Range Rover HSE and I am getting an error message reading door open when in fact it is closed. It is the driver's side rear door. The door opens and closes fine from both the outside and inside. At the same time, the window will not operate nor will the locking system. I checked the fuse and it's fine. I've disconnected and reconnected the battery to try to reset. I have tested the switches in the door panel and have power to them. I swapped the door control unit from the functioning passenger side rear door to rule it out. Also, it is a soft close door and that feature is not working. I have seen a few others mention the same or similar problems, but I haven't found anyone who has identified the root cause or solution. Anyone else have this issue and figure it out?
 

·
Registered
2013-2015 Range Rover MkIV / L405
Joined
·
586 Posts
I had something similar with my 2013 RRSC. The locking mechanism and the window did not work for the rear passenger door. Also, the amber light on the door lock did not illuminate. However, I did not receive any error messages and the soft close functioned properly. I tested the switches and replaced the fuse without any luck. I took it to the dealer and they took several days to isolate a short to the front passenger door. I am sorry that I cannot give any more specifics. Hope this helps.

Steve
 

·
Premium Member
Joined
·
1,830 Posts
I have a 2013 Range Rover HSE and I am getting an error message reading door open when in fact it is closed. It is the driver's side rear door. The door opens and closes fine from both the outside and inside. At the same time, the window will not operate nor will the locking system. I checked the fuse and it's fine. I've disconnected and reconnected the battery to try to reset. I have tested the switches in the door panel and have power to them. I swapped the door control unit from the functioning passenger side rear door to rule it out. Also, it is a soft close door and that feature is not working. I have seen a few others mention the same or similar problems, but I haven't found anyone who has identified the root cause or solution. Anyone else have this issue and figure it out?
If my memory serves, there was a software update for this.
 

·
Registered
Joined
·
606 Posts
Ok there is a tsb google P068 it updates the software. My rear passenger door lock actuator failed. At first I would arm the car, all 3 doors locked but the rear passenger door would not even lock! The horn would honk twice indicating a problem. The mirrors wouldn’t retract either. No problems when driving no error codes. So then I was told by my trusted mechanic Freddy that if I don’t hear the lock engaging when using the fob then the p068 update won’t work. So then I looked at this excellent YouTube video: https://www.jaguarforums.com/forum/xf-xfr-x250-44/rear-door-lock-actuator-199690/

it it literally is exactly like our l405 door.

I found the actuator used on eBay for 220. I took the door apart twice and both times the lock would engage but the sensor telling the car the door is locked still wouldn’t work. So the mirrors won’t retract and the horn beeps twice but the door locks. When the new used eBay part comes hopefully it will solve the problem.

Its extremely difficult to do this repair. The actuator is attached to the soft close motor and the door handle. I’m worried the cable attachment is beyond my abilities. My eBay part comes with the actuator plus cables plus soft close motor but no new door handle.

I already had one door fixed under warranty for this problem but the second door is having the problem and the car has 90k miles on it.

If if you want to attempt this then try the YouTube video.

There is another YouTube video that addresses a failed actuator motor but opening up the actual actuator is even more complex and difficult and the spindle motor is hard to swap.

Our actuators failed becuase the plastic sensor telling your car the door is shut/locked fails. My car has 91k miles on it. No one sells the sensor only the whole actuator.

270F0D01-05E4-4B70-BD71-EB36DDB1BB42.jpg 41AAD6FE-A8EE-4CEB-AF76-1BDBD2525DEF.jpg 47C333BE-8C90-4D06-864D-B17132B6AEB3.jpg E1644D8B-F76B-48E2-9EDC-7DBF37B43641.jpg F841BC01-A597-4199-BED6-6461B7D52507.jpg EE5942D7-4432-40E6-8C69-F3352591F8DF.jpg
 
1 - 4 of 4 Posts
Top