RangeRovers.net Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter #1
Hi everyone - on my 2014 5.0 Supercharged (28K miles now), I have noticed something odd recently, as follows:

When I'm in the city (San Francisco) driving, turning sharply from a stop, if I accelerate quickly, he something chatters a bit or there's a drivetrain noise I can hear/feel a bit during the heavy acceleration as I turn. Repeatable every time. Sort of a slipping feeling. not constant, but slip-slip-slip-slip maybe 4 times until the wheel straightens out. Only under heavy acceleration.

Is my differential on the way out or something? This reminds me of an old 410hp 2013 BMW M3 that had a diff problem from too many trips to track days (ha).

Is this normal? I don't believe the truck did this before I drove it cross country a few months ago (2500 miles).
 

·
Premium Member
Joined
·
1,854 Posts
had something very similar in my '17 full size. they changed the transfer case fluid and it went away. it was warranty work. I did have to take out the SA for a drive to show him. He recognized it immediately.
 

·
Registered
2016 RR Sport SC Dynamic
Joined
·
1,169 Posts
Have it on my 2016 with 46k miles as well. Coming up on service in a few weeks, will mention the transfer case fluid, thanks for the tip.
 

·
Registered
Joined
·
91 Posts
Discussion Starter #4
Interesting. thanks ... will ask the dealer about transfer case I guess

I'm under CPO but just out of factory warranty. Wonder if that's covered (i'm sure not ha)
 

·
Registered
2013-2015 Range Rover Sport
Joined
·
12 Posts
Same here with my “15 @ about 60K miles, but I’m no longer under warranty. Anxious to understand what the issue is and if I can DIY it.
 

·
Registered
Joined
·
25 Posts
I also experience similar problem. It is like avery small clunk sound that only happens when re-applying throttle. Had the dealership check on the problem bt since they can't replicate the problem they can't fix anything...
 

·
Registered
Joined
·
79 Posts
Alipapa, Exactly same for mine, started about one month ago... (51K miles).

Anyone have the spec for the oil that need to be use? Thanks!
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
69 Posts
I also experience similar problem. It is like avery small clunk sound that only happens when re-applying throttle. Had the dealership check on the problem bt since they can't replicate the problem they can't fix anything...
Only when turning or from a straight line? I've noticed two things with mine now (brand new 18, only 3200 miles):

* When reapplying throttle at low speeds or not coming to a complete stop it will lurch with a slight clunk feeling/sound
* When reapplying throttle at low speeds while wheels are turned there is an audible clunk
 

·
Registered
Joined
·
79 Posts
Correct, only a low speed... but a 3K miles she is just a little baby...
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
69 Posts
Correct, only a low speed... but a 3K miles she is just a little baby...
I honestly think it's the TCU more than anything else. I think it gets confused and doesn't gracefully go down to 2nd quickly/smoothly enough and/or doesn't engage as smoothly. I don't think it's any hardware because it doesn't happen all the time...and when it's working, it's buttery smooth.
 

·
Registered
2016 RR Sport SC Dynamic
Joined
·
1,169 Posts
Went to dealer recently and mentioned the low speed judder I get when turning the wheel. There's a TSB for it and they changed the transfer case fluid under warranty. The TSB number is LTB00906NAS5. Dealer said they have done a number of these changes.

Thanks totya for the information on the transfer case change earlier in this thread.

The parts listed for service:
Flush 1924WRR97
OIl-lubricant IYK500010 x 5
Washer IYF500030 x 4

They also "configured existing TCCM module" and did a road test. Not sure this is a DIY thing, but since there is a TSB I would push the dealer to cover it out of warranty.
 

·
Registered
2016 RR Sport SC Dynamic
Joined
·
1,169 Posts
Have not experienced it yet but I will say it was not a very common occurrence. Will report back if I do.
 

·
Registered
2019-2021 Range Rover Sport
Joined
·
101 Posts
This happens on my Velar but only on the freeway when i accelerate hard overriding the cruise control. Something judders or slips for three or four seconds , almost sound slike when you wheel spin from a standing start on a wet day when you are enetering a junction or something.
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
104 Posts
mine does it when at a complete stop, not sure if its the something similar, if I do a full turn at very low speed, sounds like my tires are rubbing not sure how to explain this, but my steering wheel gets a little bit of vibration, my S.A and Tech both noticed it, when the service was finished I was told they couldn't duplicate the noise LOL
 

·
Registered
Joined
·
91 Posts
Discussion Starter #16
Quick update. I took the Rover to Land Rover San Francisco and they actually did exactly what someone said above - the TSB. The parts listed on mine are different but TSB # is the same, have driven it around the city tonight and not noticing it anymore.

Bad news is that CPO warranty doesn't cover TSB's. Oh well. Should have mentioned this while it was still under warranty a few months back. Live and learn.
 

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
1 Posts
Dear,

My RR 4.4 TDV8 from 2010 with 110K Miles has a rattling noise when turning and (heavily) accelerating .
Is this the same as discussed or is this different?
It sounds like there is friction in the dif (or transfer box).

Any comments?
 
1 - 17 of 17 Posts
Top