Range Rovers Forum banner
1 - 16 of 16 Posts

· Registered
Joined
·
330 Posts
Discussion Starter · #1 · (Edited)
What's up with the bad def quality when it tests good. I test my def fluid before I add it to my tank. This is the second time this has popped up on me. Has anyone figured out a answer for this issue?

Update: So I hooked up my Autel and started looking at stuff. Found a few things and tried them out. None of them were working. Came across a dosing module test. At this point I had already took off the injector for DEF fluid. So I proceed to test and nothing came out of the injector. During this process I was inside the vehicle and I heard it doing something. I thought it was purging air or something. Looked under and it was dry on the ground. So I did it a second time but I was under it while it was doing it. But before it started the test I banged the injector against the exhaust with a pretty good bang. Sure enough second test it sprayed it out very good. Ground was also wet. So put it all back together and drove it freeway and city. After about 40 miles code cleared and problem fixed. Very easy to test. All you need is a T25 to take bolt completely out. Then you just push clip till it comes off.


291177
291178
 

Attachments

· Registered
Joined
·
330 Posts
Discussion Starter · #5 ·
Good write up Joe, love my Autel also...
I will check my def injector when I replace the fuel filter soon.
Ive heard there is a gasket that goes on injector. Im gonna look into myself. They say you are supposed to change whenever you take injector off. But im still issue free since the first write up. Im at 95k miles right now.
 

· Registered
Joined
·
3 Posts
Was your injector sticking too?
Yes it was. I’m a diesel mechanic @ UPS and we have had several issues with def crystallizing on the dosing injector on trucks that are seldom used. Didn’t cross my mind when I had the issue with my Range Rover until I read your article. Was still covered under extended warranty but 3 1/2 week waiting list at the local dealership.
 

· Registered
Joined
·
1 Posts
Thanks for the great article. I came across it after I had no miles to engine restart left. Does anyone know if the Autel or another vendor has the capability of resetting this error code so the vehicle can be started?

Thanks
Alex
 

· Registered
2018 L405 HSE Td6
Joined
·
12 Posts
Thanks for the great article. I came across it after I had no miles to engine restart left. Does anyone know if the Autel or another vendor has the capability of resetting this error code so the vehicle can be started?

Thanks
Alex
Hi Alex,
I got the Autel today and was able to reset the error. My problem started with the "Incorrect Diesel Exhaust Message", I filled up the AdBlue and cleaned the injector as described here. After clearing the error with the Autel it gives you the "Dosing Malfunction Error" which my Autel model was able to clear as well; select Reset Selective Catalytic Reduction (SCR) quality monitor as you can see in the picture, and you should be ok.

Good luck,

Product Communication Device Mobile device Output device Portable communications device

.
 

· Registered
Joined
·
4 Posts
Some of the features the Autel has. Came in handy today. This thing has already paid for itself. Plus I scored it for a lil over 200.00
I have the same problem now.. I have a icarsoft LR v.3 and it doesn't seem to have any o these features.. The no start countdown is loping off chunks of miles till no start that I am afraid to drive it.. Says I have 31 miles and 50 miles ago it said I had 249... The thing has been running better than good, getting 30+mpg combined and then the computer took over.. Does anyone know if these test and a miles to zero reset is available on the icarsoft? Otherwise, where is the best place to purchase the Auto? Thanks in advance.. Juneau AK
 

· Registered
Joined
·
4 Posts
Thanks for the great article. I came across it after I had no miles to engine restart left. Does anyone know if the Autel or another vendor has the capability of resetting this error code so the vehicle can be started?

Thanks
Alex
We are exactly at this question you just asked.. It stated with 249 and we only drove about 50 miles but had to turn the car on and off a few times.. Sitting in our driveway now with only 31.. Afraid to start until we have a reset option.. WE are in Juneau Alaska and we'll have to put it on barge to Washington if that happens.. It was running awesome up until the computer took over.. then we noticed it running rougher after the first 20 miles went off. I pulled the O2 sensor and cleaned it.. The DEF nozzle was clean and without crystallization.. We know the fluid is good.. Hope everyone get through this without getting extorted at the shop. Peace!
 

· Premium Member
2016 TD6 RR L405
Joined
·
4 Posts
Just cleaned mine out. Completely clogged up. Just cleaned it up and put back together. How do I clear the amber warning light?
I’ve been through this situation about 8 times in the past, including yesterday. I will top off the DEF fluid & I have an Autel tablet that I normally run a prime and pressure test. After that I just red line it in sport mode on the highway for about 50-60 miles, +\- 20 miles. I’ve realised that if I don’t drive mine frequently, this message pops up. This most frequent issue I’ve only put AdBlue, so I know it’s not a quality issue.
 

· Registered
Joined
·
3 Posts
I filled the adblu about 3 months ago with 18 litres so I know it's not the quantity. The message hasn't cleared. Still have 530 miles to run.
The value I cleared was clogged with what looked like lime scale grey in colour with a very small hole in the centre. I only cleared this on Sunday so need to take the car out for a long drive
 
1 - 16 of 16 Posts
Top