RangeRovers.net Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi people,
new to the forum,looking if anyone has come across my problem before,
2010 L322 3.6 tdv8
2 week`s ago on a really hot day i went to pick my grandson up,car started fine but it was roasting hot so air con went on straight away, 10 minuted into the drive i had a warning come on to the touch screen saying low voltage and the every thing started to shut down, first the touch screen then the air con then the LCD cluster lit up like a Christmas tree then went black,
the engine was still running fine so pulled over and switched the engine off hoping that everything would re-set, wrong thing to do , message came up on the dash, NO SMART KEY FOUND, sat there for ages to no avail, walked to get my spare spare smart key but still nothing, decided to leave it over night and call recovery, that night managed to find a few threads on tinterweb about placing the smart key below the steering wheel, went back next morning and tied this and managed to get it started but still had no central locking,electric windows,LCD instrument cluster so on and so on,
drove it down to my local indy JLR garage where they plugged it in to Land Rover main dealer hub, came back with no medium speed canbus,
to cut a very long story a little shorter,they`ve swapped the battery , Central junction box (BCU) and the smart key ECU, all brand new genuine parts and it`s still saying no medium speed canbus,
oh and by the way the car now won`t start because they`ve managed to clear the code from the smart key somehow so it will not start when you hold the key under the steering wheel anymore /:(
any help would be very much appreciated,losing the will to live at the moment....
 
1 - 2 of 2 Posts
Top