RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
This truck has had some issues. Here's our problems now...

After recent oil change, we started smelling burning oil and even saw smoke from the tailpipe. Took it in and they determined that we needed to replace the valve cover gasket, real main seal and coolant cover plate. Of course that job runs approx $1700 at the dealership. We are going to try to get another local mechanic to do it because he has cheaper labor rates - any suggestiion on where we can get the parts from? We looked and saw some online at partsgeek.com

The other issue its having is that the battery is always dying. We had the dealership check this back in January...told us that the batter we had in there was not "strong enough". We allowed them to replace it for $150. We stopped driving it because of the oil leak (didn't want to cause more problems) - battery died - with new battery. Okay, so we take it in and have them check it, during the same visit they determined we needed the gaskets replaced and said that the battery THEY put in there was a bad battery and it needed to be replaced. Okay, since they have no control of the new battery dying, we had to pay them $52.50 to install it. CRAZINESS!

But what's really crazy is - THE NEW BATTERY IS NOW DEAD! So obviously something is killing the battery, which is what we initially told them. I can't afford to keep peeling out diagnostic fees for them to not know what the real problem is...anyone had this issue?
 

·
Administrator
Joined
·
27,818 Posts
Sounds like you either are not driving the truck enough for the alternator to charge the battery or the alternator is dying.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
The alternator has been replaced twice - the second one was because the dealership said that the first went bad, since it was within the warranty period, I didn't have to be concerned about paying for it. We found on this site info about the HEVAC system possibly killing the battery..the dealership never mentioned this though! Why would they not know? We plan on printing it and taking it to the shop!
 
G

·
Guest
Joined
·
0 Posts
nijones25 said:
The alternator has been replaced twice - the second one was because the dealership said that the first went bad, since it was within the warranty period, I didn't have to be concerned about paying for it. We found on this site info about the HEVAC system possibly killing the battery..the dealership never mentioned this though! Why would they not know? We plan on printing it and taking it to the shop!
Dealers are not as knowledgable as most people think they should be.

Pull Fuse #64 (50 amp fuse on the far bottom right inside glovebox) if this fixes your issue then search quiescent battery drain.
 

·
Administrator
Joined
·
27,818 Posts
Mr RR is dead on. Dealers look at a grid to inform them what to replace. Dealers no longer do trouble shooting. Trouble shhoting is far too time consuming in their grand scheme of cattle call customer service. They don;t give a rip about fixing existing items, they only want to replace and charge. They don;t care if they charge a warranty sale or an owner sale. In and out, charge it up is the carma at LR dealers.
 
1 - 5 of 5 Posts
Top