RangeRovers.net Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have searched the posts for dash lights out and I think they are referring to the SRS, check engine, ABS etc. My problem is not this. I do not have any illumination bulbs working in my dash pod or across the dash for night time driving. Is this the switch on the turn signal stalk, a bad ground or god forbid the becm?
 

·
Registered
Joined
·
701 Posts
Its probably just the instrument cluster. Have you noticed any other unusual behavior?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
lrscott said:
Its probably just the instrument cluster. Have you noticed any other unusual behavior?
Just once at the same time the light issue started, on a very cold morning the temperature gauge acted abnormally. Would a problem with the instrument cluster also cause the dash lights to be out across the front of the dash? Thanks
 

·
SUPER MODERATOR
Joined
·
27,784 Posts
Sounds like it's time to clean and tighten up some grounds. :thumb: I would download RAVE from the internet and look up the graound locations for your lights and gauges.
 

·
Registered
Joined
·
300 Posts
In my case, the dimmer control on the stalk was defective. It would "dim out" the light but not brighten them up again. What I found works was to remove the negative terminal of the battery, that resets it. Then, of course, you get to set all your windows, reintroduce the radio code, reprogram all your radio stations, etc. But the dash lights are back on.
 

·
Registered
Joined
·
640 Posts
Do they work at all? or I don't suppose you have Memory Seats and have inadvertently set them with the Lights Switched on, and the panel lights set very low so that when you start the truck they automaticaly go to that setting.
Although saying that you would still be able to adjust the intensity on the stalk if they were working,then they revert to memory when the truck's started.

Only a thought.

Cheers
 

·
Registered
Joined
·
4 Posts
Discussion Starter #9
Unhooking the battery had no affect. The only thing thats lit is the transmission gear changer.
 

·
Registered
Joined
·
56 Posts
Any luck sorting this out?

in my case i dimmed the lights to 'off' accidentally, and then found i couldnt get them to turn on again, so I too am driving around with a flashlight!

Gordon
 

·
Registered
Joined
·
4 Posts
Discussion Starter #11
Update. I have been distracted building a 4.6 engine for my 01 D2. Coming home from tennis this evening driving the dark P38 I got to thinking about the post suggesting it could be related to a memory seat position. I had tried disconnecting the battery to no avail. So I got out of the truck with the lights on a pushed the top button. Seat moved around still no dash lights. Hit the second position the seat moved around and when the motion stopped I got a beap and viola my dash lights are back!!!!!!!!!!!!!!!!!!!!!! You guys effing rock. Thanks, thanks, thanks again.
 

·
Registered
Joined
·
7 Posts
i have problem with check engine it not functioning at all , when i start car every cluster light are on except check engine if anyone knows how to fix please help me.
kind regards
 

·
Registered
Joined
·
7 Posts
Put a new bulb in it?
there is no bulbs it is on diode i swap it but everything is ok. someone said that maybe check engine feature turned off using some program :( i don't know what to do
is there a chance that someone done some programing thing or just changing diode bulb it will help ?
 

·
Super Moderator
Joined
·
1,932 Posts
What car are you talking about? The P38 has normal capless bulbs in the instrument cluster.
 

·
Super Moderator
Joined
·
1,932 Posts
In that case you might do better asking in the L320 forum, this is the P38 forum for 94-2002 models.
 
1 - 18 of 18 Posts
Top