RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1
I was reading about similar cases and they seem to point to the accumulator. Since this is my first Rover I thought i would put it out there.

Here's the deal. In my 2001 HSE when i first touch the brakes the TC and Parking Brake dash lights come on and i think the ABS light. The only flash for like half a second. If I touch the pedal and apply pressure to it slowly I can get it so they don't flash. I do have brake lights as I read it could be the switch.

Does this sound like an accumulator problem?

Thanks in advance
 

·
Registered
Joined
·
517 Posts
It does sound like accumulator. Try following test - turn ignition key on and wait for pump to stop charging accumulator. Then press brake pedal and if pump starts running straight away that would pretty much point to accumulator. You should be able to apply the brakes at least 3 times before it runs.
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
388 Posts
nosaint said:
I was reading about similar cases and they seem to point to the accumulator. Since this is my first Rover I thought i would put it out there.

Here's the deal. In my 2001 HSE when i first touch the brakes the TC and Parking Brake dash lights come on and i think the ABS light. The only flash for like half a second. If I touch the pedal and apply pressure to it slowly I can get it so they don't flash. I do have brake lights as I read it could be the switch.

Does this sound like an accumulator problem?

Thanks in advance
Yep, I would suggest accumulator. Russell.
 

·
Registered
Joined
·
86 Posts
Discussion Starter #4
update to say that i purchased a new accumulator and no more dash flash.
 
1 - 4 of 4 Posts
Top