Range Rovers Forum banner
1 - 8 of 8 Posts

·
Registered
1995-2002 Range Rover P38A
Joined
·
710 Posts
Discussion Starter · #1 ·
So, a first for me, car was fine last week but today she started fine abs Srs lights came on and went off as usual but rev counter speedo not working . Havent dug out my faultmate extreme yet but wondered for a quick pointer from the
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
710 Posts
Discussion Starter · #3 ·
Ha, thank you for starting my quest, I am, a typical man and intrinsically lazy so not realising the dash has a power fuse I’d be stumped before I started. Will report back tomorrow
 

·
Administrator
Joined
·
4,229 Posts
If fuse 1 is OK, take the dash surround off, pull the large plug on the bottom RH side of the instrument cluster, give it a squirt of contact cleaner and put it back.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
710 Posts
Discussion Starter · #5 ·
Cheers Rich, the panels are off anyway as I need to swap the cruise ecu, so either way I’m hoping for service to be resumed quickly
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
710 Posts
Discussion Starter · #6 ·
not the fuse, unplugged the main white connector re plugged it in and briefly service was resumed. Unplugged it again, no signs of corrosion but have sprayed contact cleaner be waiting for it to evaporate before plugging it back in
 

·
Administrator
Joined
·
4,229 Posts
I usually spray then plug back in, that way both contacts get a good dose.
 
1 - 8 of 8 Posts
Top