Range Rovers Forum banner
1 - 5 of 5 Posts

·
Registered
2006-2009 Range Rover Sport
Joined
·
44 Posts
Discussion Starter · #1 ·
Replacing the spiral cassette coupler in the steering column fixed a litany of issues in my steering wheel controls, but from time to time I'm still getting the Cruise Control Not Permitted Issue popping up albeit far less often and more self-correcting than before when it was always there.

Initially I thought it was related to an old battery as I was getting the HDC not available message that stems from low voltage (replacing the battery has completely fixed that) which I understand Land Rovers are in general quite finicky about. But that didn't remedy the cruise control.

GAP IID shows a fault of P0579-00 (2A) Speed control multi-function input A - circuit range/performance, easily cleared, and things go back to normal.

Any and all wisdom, advice, and/or hacks is/are appreciated.
 

·
Registered
Joined
·
1 Posts
Replacing the spiral cassette coupler in the steering column fixed a litany of issues in my steering wheel controls, but from time to time I'm still getting the Cruise Control Not Permitted Issue popping up albeit far less often and more self-correcting than before when it was always there.

Initially I thought it was related to an old battery as I was getting the HDC not available message that stems from low voltage (replacing the battery has completely fixed that) which I understand Land Rovers are in general quite finicky about. But that didn't remedy the cruise control.

GAP IID shows a fault of P0579-00 (2A) Speed control multi-function input A - circuit range/performance, easily cleared, and things go back to normal.

Any and all wisdom, advice, and/or hacks is/are appreciated.

!!!!! Im having the same issue, there must be someone some where who has managed to find the fix for this!!!! Please Help???
 

·
Registered
2006-2009 Range Rover Sport
Joined
·
44 Posts
Discussion Starter · #3 ·
!!!!! Im having the same issue, there must be someone some where who has managed to find the fix for this!!!! Please Help???
Not yet. And I swapped out the switchpod and then cruise control worked perfectly for about 2 months and then once again deteriorated to barely working intermittently. :( Back to the drawing board.
 

·
Registered
2011 RRS 3.0 TDV6 HSE LUXURY
Joined
·
126 Posts
Sounds like you need to check the wiring for good connection and faulty grounds. If the cassette got fried it may have damaged another connection else where.
 
  • Like
Reactions: cba20k
1 - 5 of 5 Posts
Top