RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
Ok here is the run down AGAIN. Found out(through this awesome site thanks so much) the first thing to check is L7 and L6 relays. Did that and sure enough relay L6 was burned out and when changed voila the blowers started working!But only for a short time and intermittingly. Well had my mechanic checked the HEVAC and both motors were bad.Order 2 new ones.So while waiting for motors to come in found a control panel for 150.00( that's right brand new in box and bubble wrapped) since the Yahoo who sold me my p38 was pressing the LCD screen and trying to convince me that it was a touch screen while trying to sell me the thing. I bought it. Anyways changed the control panel with new one and worked perfect.Next motors came in changed both and had a little charged on the AC.Well got home worked perfect but dreaded book sign now showing. First question Why now and not when I first put the control panel in? Second question everything worked great up until 2 months latr then nothing just like before. Checked relays again no burnt ones and switched them around and then it worked great.Were the relays bad or is the fuse box going? Third question 2 days latr air running fine since it was 98 degrees in Arkansas and air went out not motors but cold air. So I shut it down for about 10 min and pressed the auto button then A/C off then pushed front vent button on again to start air then all of a sudden cold air comes on again.Are the relays bad? I had a Range Rover mechanic told me that whenever you change the motors you always replace relays L7 and L6 with news one since they may be worn down is this true? And was also told that relays have a tendency to go in and out during hot temps.Lastly stopped for some food a few hours latr and motors were slow AGAIN to come back on. With all of the work done on my HEVAC is this just relays or the fuse box going out? Or am I just missing something on all of this? We will be going to the dealer to have it scanned for the book symbol and any other issues. As much as I don't want to do this I feel this is my only hope in finding the issue Any help would truly be much appreciated you guys have help so much and I have been able to help others with the knowledge I have gotten from this web page and each person who has responded. Thanks for allowing me this long post!
 

·
Registered
Joined
·
59 Posts
Discussion Starter #4
Its been a long day of ups and downs and what better place to vent my frustration but to my Ranger brothers. Seriously any help would be grateful
 

·
Registered
Joined
·
976 Posts
I saw 2 questions in your comment, I think. Here are my take on them.

-Book sign. Well, the dumb ass yahoo who previously owned your truck was trying to work the "touch screen" AC control, and as a result messed up the connections to the LCD display. The book sign was probably always present, just that the screen was messed up. Screen on these displays lose pixels all the time w/o some guy touching it all the time, so you can imagine what's gonna happen if somebody is touching it all the time.

-A/C losing cold air intermittently. I think your compressor clutch is going. Next time, w/ your AC on, open up the bonnet and see how the clutch is engaging. I bet you need a new one. Of course, if you're lucky, the system is just low on refrigerant, and cutting off as a safety precaution to save itself.

If you're not mechanically inclined, I would suggest that you take your truck to a RR shop, either a dealership or an indie. From your description of your mechanic, sounds like just a local mechanic w/o much RR experience. If you take your RR to a shop well versed in RRs, they can scan the HVAC codes.
 
1 - 6 of 6 Posts
Top