RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
334 Posts
Discussion Starter #1
I'm having a strange intermittent problem with my coolant level warning light.

My coolant level appears to be fine (based on a visual inspection). I also (mostly) drained and refilled the coolant over the weekend, but this problem predates this.

When I'm driving, the coolant light will blink on and off, for about ten minutes. Then it will be fine for a while. Then it might start up again.

My understanding is this light is connected to the coolant level sensor in the expansion tank. However, this seems to have been disconnected by a previous 'enterprising' owner. There are a pair of olive green cables taped off near the sensor, so I assume that's the cables.

Is there another circuit or sensor for this warning light? I'm confused as to why the light is even coming on at all if my assumptions about the cables being cut are correct....

Thanks,
James
 

·
Registered
Joined
·
125 Posts
James,that warning lt is as i assume prone to give false alarms..but it is good when it works..I replaced mine when it went "kaputt"..it was not expencive item!I recommend to replace that one..as it gives early warning when you have a real coolant loss.

Rgds:Jukka
RR92 Westminster 4.6
-73 Rover P6 3500Efi
 

·
Registered
Joined
·
334 Posts
Discussion Starter #4
Yep, I should probably start with checking this rogue wiring I have and seeing if it is actually connected to the warning light, and if so look at replacing the sensor in the coolant expansion tank.

Anyone any ideas where to get a new sensor?

Thanks,
James
 

·
Registered
Joined
·
334 Posts
Discussion Starter #5
I got to the bottom of this.
When the connection is made, the light stays off. When the connection is broken (ie the fluid level is low) the light comes on.

The wires I mentioned were connected together by a bent piece of wire. Which was loose, and causing the light to randomly go on and off. If temporarily connected the wires together a little better, to keep the light off for now, and I'm trying to source a new coolant level sensor.

I'll see if the local Stealership has one...
 
1 - 5 of 5 Posts
Top