RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
248 Posts
Discussion Starter #1
Hi guys!

Came back from a wonderful 2000 miles-trip two weeks ago without any problem (!!!), just realized that one air spring was worn out. I thought no big deal, brought the car to the dealer to change the thing. Left the Rover there over night, in the morning they couldn't start it anymore. With all those other cars there, no big surprise. But they couldn't start it with the EKA, it did not work. They connected it to a computer and told me that the BeCM is programmed as 'manual gearbox' and has some other things which do not come usually with a V8, but they couldn't change it to another country or reprogram it. Ever since the alarm does not work, neither do the remotes, but all the other programed stuff (follow-me-home, radio-settings, etc.) were still there...

I know that the drivers door lock has been changed once (it's darker than all the other door-handles). How can I check if it is connected properly? I think this is why the EKA doesn't work.
And that's my biggest concern. I mean, it's not unusual for a Rover to have a sudden battery drain, but if the EKA does not work, how am I going to start the car?
The not working EKA stops me from trying to program the remotes (with the drain battery - key into position two - method).

And how concerned should I be about the weird BeCM? :crybaby2:

Oohhh, and my rear wiper is broken, it just hangs down and I can move it with my fingers... Is there a fix? The motor still works, I can hear it. It's just the wiper that does not move. :think:

Thanks in advance.



 

·
Registered
Joined
·
135 Posts
Don't do anything about the BeCM until you have left the truck off the battery overnight. Hook it back up in the morning and see if your problems are solved. Don' know why but it works.
A far as the rear wiper I'm just going to assume the motor needs to be replaced. Check the Rave!
 

·
LEGACY VENDOR
1995-2002 Range Rover P38A
Joined
·
2,064 Posts
The rear wiper has a plastic cover which can be removed with your fingers, then you will see a nut that holds it on the splined shaft of the motor. See if the nut has come loose. If not you should be able to see the shaft spin freely on the wiper arm. If thats the case you may be able to replace the wiper arm.
Which of course I have.. :lol: :lol:

p.s. I have the motor as well :lol: :lol: :lol:
 

·
Registered
Joined
·
248 Posts
Discussion Starter #4
wrldky said:
... left the truck off the battery overnight...
I'll try that, but first I have to make the EKA work. :roll:

Scotty said:
The rear wiper has a plastic cover which can be removed with your fingers, then you will see a nut that holds it on the splined shaft of the motor. See if the nut has come loose. If not you should be able to see the shaft spin freely on the wiper arm. If thats the case you may be able to replace the wiper arm.
I'll check that and I'll contact you when I know what I need. Thanks!
 
1 - 4 of 4 Posts
Top