RangeRovers.net Forum banner

1 - 8 of 8 Posts

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
5 Posts
Discussion Starter #1
I have a 2006 TD6 and it lets out a rather alamingly large cloud of grey smoke which smells of burnt diesel. Its not coming out of the exhaust I wondered could it be the pre-heater as it has only just started with the cold weather, it is also accompanied with a whinning noise around the LHS front of passenger. If it is this does this mean it is broken or is this normal ?
 

·
Registered
Joined
·
62 Posts
Hi,

My '06 did exactly the same thing. LR Replaced the Pre-heater under warranty, fixing the problem.
They said there was a known issue with these units, so if your out of your warranty period they may replace it FOC.

Good luck....
 

·
Premium Member
2002-2005 Range Rover MkIII / L322
Joined
·
1,973 Posts
Sounds like it may have failed to ignite propperly? What happens if you set it manually?

Dan
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
5 Posts
Discussion Starter #5
How do I set it manually ? when I looked it was on a timer you set to come on, can you just turn it on somehow ?
 

·
Premium Member
2002-2005 Range Rover MkIII / L322
Joined
·
1,973 Posts
Buff_Rio said:
How do I set it manually ? when I looked it was on a timer you set to come on, can you just turn it on somehow ?
Set the timer to a different time? ie 5 minutes in the future.
 

·
Registered
Joined
·
41 Posts
paultuk said:
Hi,

My '06 did exactly the same thing. LR Replaced the Pre-heater under warranty, fixing the problem.
They said there was a known issue with these units, so if your out of your warranty period they may replace it FOC.

Good luck....
Paultuk,

I have the same problem. These last few months I have noticed smoke coming out of the engine bay which is very acrid. The last few winters I was aware of the diesel pre-heater noise but never the smoke. It is now quite concerning when I am sitting at traffic lights and the front of the car is bathed in white smoke from under the bonnet. Any more information on what the problem might be? I have found with LRUK that, although they have been very helpful, it helps to get in touch with more detail about what the known problem might be. A few technical details would really help if you, or any of the other posters, know more about this problem. Thanks in advance.

d5gg
 

·
Registered
Joined
·
41 Posts
Sorry for the bump. However, still having a problem at start up with clouds of noxious smoke coming from under the bonnet. Does anyone know whether this is a known problem with pre-heaters, and if so what exactly is the fault. I have recently moved and the local LR garage is very poor so I will probably take it to another garage but would like to know more about the fault before I go in. Thanks in advance.

d5gg
 
1 - 8 of 8 Posts
Top