RangeRovers.net Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
We have a 2010 RRS that is barely two months old. A couple weeks ago the CEL came on so I brought it in to the dealer. This is what they wrote on the invoice: "852 oil filler cap not fully seated Ran SDD found P2099-00 bank 2 fuel trim too rich. Ran data logger and monitored oxygen sensors. Found sensors are moving accordingly when removing oil filler cap. Found cap was not tightened down. Reinstalled oil filler cap correctly. Cleared faults and PCM adaptions." No charge, but as they were pulling the car up for me, the CEL light came on again. So I requested they fix it again, and drove the loaner XF home. I ended up in the XF for 3 nights, missing the RRS the entire time. Finally got it back less than a week ago. This time, this is what they wrote on the invoice: "875 Found bank 2 (drivers side) downstream oxygen sensor has failed. Ran SDD found P2099-00. Fault returns with every drive sets light on second drive cycle. Contacted tech line. Advised to check fuel adaptions, swap rear oxygen sensors, reset adaptions, clear faults and test drive. Found unable to swap sensors due to different length pig tail harness on other sensor. Had to clear adaptions 3 times SDD failed on all other tries. Could not save fuel adaptions file view. SDD had a general fault. Swapped in a rear o2 sensor from another vehicle on the lot. Cleared adaptions from legacy IDS and cleared faults. Fault did not return after oxygen sensor replacement. Removed sensor and installed new sensor. Installed old sensor back into stock unit. Test drove and fault does not return. Check ok after repair."

This morning the CEL is back. Any ideas guys? The car was at 850 miles when the first CEL came on, 855 when it came on a second time, and is at about 1100 miles now. It was a May 2010 build. Ohio is a lemon law state I believe, so they get one more chance to get it right before it's officially a lemon. I don't want another car or a repurchase or a refund, I just want the problem to go away.
 

·
LIFETIME CONTRIBUTOR
2006-2009 Range Rover Sport
Joined
·
11,013 Posts
Wow, the wording in that second work order makes my head spin: So detailed, and yet so undecipherable! Good luck to them figuring it out on their third attempt.
 

·
Registered
Joined
·
30 Posts
Bangkokiscool;

I have a 2010 RRS and the CEL light came on around 3k miles the day after I pumped gas. Thinking it was due to the gas cap not being tight enough, I tighten it again but the cel remained on.
Took it to the dealer, they cleared the error and gave it back to me. After 4 days the cel appeared again.
Took it again to the dealer and this time they kept the car all day. They did the software update according to Q093 and also clear the CEL light. Its been a week and everything seems ok. Maybe the software update did the trick
Hope this helps;

Moses
 

·
Registered
Joined
·
17 Posts
Discussion Starter #4
Thanks very much for that pointer. My VIN falls outside that range. It was a May 2010 build, so presumably it has the latest software.

Latest update is that the car is still in the shop. Tomorrow is the fourth day. Dealer says they've replaced the wiring harness and are now test driving it to see if the wiring harness (to the o2 sensor) is the cause. Extremely frustrating. Today is Day 30 of ownership, and the car has been in the shop for 8 of those days, and counting. If I wanted to drive a POS XF I'd have bought one.
 

·
Premium Member
2006-2009 Range Rover Sport
Joined
·
5,175 Posts
bangkokiscool said:
Thanks very much for that pointer. My VIN falls outside that range. It was a May 2010 build, so presumably it has the latest software.

Latest update is that the car is still in the shop. Tomorrow is the fourth day. Dealer says they've replaced the wiring harness and are now test driving it to see if the wiring harness (to the o2 sensor) is the cause. Extremely frustrating. Today is Day 30 of ownership, and the car has been in the shop for 8 of those days, and counting. If I wanted to drive a POS XF I'd have bought one.
The XF is a POS?
 

·
Registered
Joined
·
17 Posts
Discussion Starter #6
It's no Range Rover, which is what I paid for. Unlike the RRS, which defines a class by itself, the XF isn't competitive with a 5 series or A6, or even a 3 series or A4. It is, however, apparently much more reliable than my RRS.

Dealer called and said they are keeping the car until Tuesday. Picked up the car on June 29, and it has so far spent 8 nights at the dealer in that first month of ownership. By the time I pick it up at the dealer on Tuesday if it's ready by then, make that 12 nights. It's my worst nightmare of owning a Land Rover product coming true before my very eyes. $66,000, one month old, and no one seems to know how to fix a check engine light. :!:
 

·
Registered
Joined
·
55 Posts
At this point, I would push the lemon issue with Land Rover USA knowing that in your original post you were hesitant to go that route. Giving you a loaner for a couple weeks is not compensation for this headache. At the bare minimum, I would get the ball rolling and see where it takes or gets you. Forums like this are great, however, 99% of us are LR enthusiasts that love the vehicle and would rather LR fix the issue. IMO there is absolutely no way I would allow this to continue if I were in your shoes.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #8
Well, after 15 nights at the dealership, the dealer is ready for me to pick up the car tomorrow but is not willing to say that the CEL problem has gone away. It is "learning adaptions" and needs miles to be put on it before they can say whether their latest fix (new catalytic converter) fixed the problem. Over the last two weeks the dealer has put 600 miles on the car. It had 1000 miles when it went in.

Has anyone had any luck trying to get JLR in Mahwah to pony up some compensation in a situation like this? I'm not looking for money necessarily, but 600 miles is a lot of miles to put on a car. I don't blame the dealer, apparently they've been working under the direction of the district manager.
 

·
Registered
Joined
·
30 Posts
bangkokiscool,

An update to my post above.

The CEL light appeared again. Took the RRS to the dealer and the head of the service department call the Land Rover Tech Line.
They instructed the service department to change injector #5 which apparently is failing, although only momentarily, when I start the RRS with a cold engine. They order the injector and it will arrive in one month. Meanwhile, according to the service guy, I can drive the car without worries until the part comes in.
I hope that I explained this issue correctly since it involves technical terms which I am not familiar with.
My RRS is a 2010 HSE.
Hope this helps;
 

·
Registered
Joined
·
55 Posts
At this point, why wouldn't you just claim lemon in your state? Personally I would contact JLR and let them know you plan on moving in that direction. You obviously have been more than tolerant with their attemt to service this issue. On top of all that....you now have another 600 miles on your car. You have to be careful with asking for some sort of compensation because they may not allow a buyback or lemon claim.

There's absolutely no reason to go through all of this with a $60k plus vehicle, none.
 

·
Registered
Joined
·
13 Posts
I had the Check Engine Light problem for a while and it was fixed last week... they found faulty gaskets (x2 and changed 6 others). They called it an air leak.

But hey... the car has been up and down the Autobahn in Germany at high speed (too many times), going through a hot summer on the US east coast, and is now taking a beating in absolutely crazy traffic in Seoul, South Korea.

8 gaskets was well worth it (and fixed under warranty) 8)
 

·
Registered
Joined
·
17 Posts
Discussion Starter #12
Just a quick update on my saga -- I finally have the car back in my possession. The dealer ended up putting 800 miles on it, and unfortunately returned it terrible condition, with scuff marks throughout including the rear seat. It was obvious they went on a road trip with passengers, probably small kids. To top it off there were discarded food wrappers and a grocery store receipt for beer in the rear passenger door pocket. So at this point I was pretty apoplectic, at both the dealer and LR.

Can't call it a lemon yet in Ohio because it's still on the third service call. I have possession, but the dealer hasn't closed out the ticket yet. So far the CEL hasn't come back on. In the meantime LR has offered me some compensation, and after chewing out the dealer they picked it up and left me a RR while they detailed the interior and exterior (looks great now).

It was interesting driving a RR for a couple of nights. I was surprised at how much BMW DNA is left on that vehicle, small things like the cold air temperature dial for the center outlets, the steering and suspension tuning, even the silence when you double press the lock door button on the remote, are all BMW touches. I found myself really disliking the TFT video screen that simulates instrument gauges -- it looked very cartoonish and the needles didn't sweep smoothly. It was also not integrated with navi, phone or audio functions at all, which is disappointing. And the stereo wasn't nearly as good as the one in the RRS. I have to say I was happy to see it go (but the carpeted floor mats were really really nice, wish I had those on the RRS).
 

·
Registered
Joined
·
55 Posts
Sounds to me like you just may have the worst dealer ever, 800 miles extra on the car while they return it in piss condition? You've got to be kidding me. A RR and a full detail is not compensation in the slightest. How long is this ticket going to remain open? I have to say that you sound like the most patient customer EVER :lol: !
 

·
Registered
Joined
·
1 Posts
I know this is an old thread, but this problem looks exactly like the one I'm currently having. I bought my RRS last year and since day 1 it's had the check engine light on. Before the light goes on, the "Fuel Filler Door" warning illuminates in the driver display. If the warning remains on for more than 2 starts, the CEL comes on permanently.

I took the vehicle to the dealer who originally didn't know what the problem was, but turned the light off anyways. Sure enough, it went right back on within a few starts. The second time I took it in, they said they needed to keep it for a few days so they could get some answers from Britain. That didn't work out and now I just got it back from the dealer again, supposedly "fixed" with this language on the work order -- "Fuel vapor leak at charcole canister seal"- "Performed evaps leak test, performed DMTL leak test and EMS diagnosis found leak at canister seal." - "Replaced seal, retested system, OK"

Honestly, do these people really know what the problem is and how to fix it? I'm actually not even sure what the charcoal canister or its seal is for... I imagine it's a fuel system issue??? :?:
 

·
Registered
Joined
·
1 Posts
I have a 2006 RRS. The check engine light goes on when the temp drops below 50. I was always told it was the spark plugs or coolant. I have given up on even trying to get it fixed now that it is out of warranty. I just always know it goes off when it hits 65. I guess if it ever doesn't, I will take it in. I love the vehicle so I just deal with it's little issues.
 

·
Premium Member
2006-2009 Range Rover Sport
Joined
·
5,175 Posts
I have a 2006 RRS. The check engine light goes on when the temp drops below 50. I was always told it was the spark plugs or coolant. I have given up on even trying to get it fixed now that it is out of warranty. I just always know it goes off when it hits 65. I guess if it ever doesn't, I will take it in. I love the vehicle so I just deal with it's little issues.
I'd check first for an air temp sensor gone bad. Then coolant.

Have you downloaded the DTC's and checked for a temperature sensor malfunction?

http://www.obd-codes.com/trouble_codes/landrover/
 

·
Registered
2010-2012 Range Rover Sport
Joined
·
36 Posts
For whatever it's worth, not that I have any powertrain issues whatsoever with my <1 month old RRS, the service tech called me this morning to go over my stuff (it's in for those brake squeal and infotainment "lockup" TSBs), I did print out and leave in the car the TSB for the engine misfire/CEL issue ... and he asked me about it. When I told him I had no issues at all but printed it for him "just to look at it" he told me yes they've seen this happen on the 5.0L's and the correlation they found was due to customers filling up the cars with regular gas (or sh*tty gas I guess).

I obviously can't confirm this to you guys but that's what he told me, and well, you can take it as you wish, but if even partially true, it says something about the additives delta that the fuel provides have between regular and premium ...

Anyway, I personally do 93-octane from Sunoco/Shell/etc so I don't really care but if I ever get a CEL I'll let u guys know ;)
 

·
Registered
Joined
·
42 Posts
My 2011 HSE was purchased in May of this year and has been flawless with a couple of issues. About a month ago, I got a message saying my fuel cap was not on correctly and when I checked the fuel cap, it is tight. This has come up a handful of times. When I was in for a free 6 months service and they reseted the system, it has come up twice again. On top of that, I got the amber engine light coming on the dash as well and after two days, it is still there. Guess I will be going in to see if I have the issues you do. Can someone point me to this service bulletin? I tried searching but could not find.

Also, when I go into the display where you can change your settings, trip meter, etc. I do not have the Service Menu. Any idea how I can see this?

Thanks
 

·
Registered
2019-2021 Range Rover Sport
Joined
·
288 Posts
I think you have to have the vehicle in PARK, then open the hood/bonnet. Ignition ON. Then go back to the menu.
 

·
Registered
Joined
·
42 Posts
Thanks, I'll give that a go in the morning. Service set for next Wed to check on the gas cap and engine light. I was told driving as is should be a non issue so hopefully the car doesn't break down on a 180 mile road trip this weekend.
 
1 - 20 of 21 Posts
Top