RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
LEGACY VENDOR
1995-2002 Range Rover P38A
Joined
·
2,064 Posts
Discussion Starter #1
while stationary, car running my engin light came on. I checked for codes with a top end code reader, the unit said there were no codes stored, I pushed erase anyways and still no codes were stored. Yet the light is still on any thoughts ? I looked in search but did not find anything, I'll try different words.


Scotty :(
 

·
Administrator
Joined
·
27,834 Posts
Is it the check engine light or might it be the service engine soon light? It may also be something LR specific that a standard code reader is unable to catch.
 

·
LEGACY VENDOR
1995-2002 Range Rover P38A
Joined
·
2,064 Posts
Discussion Starter #3
it's a check engine light So if it's a land rover only code would it still say no codes found? And what kind of codes would that be?
 

·
Registered
Joined
·
400 Posts
Keep trying the code reader, I had similar problems with mine. It took a few trys and jiggling of the OBD socket to get mine to read. Make sure the ignition is on but the engine shouldn't be running. The other solution is just wait. My CEL often comes on if I am idling to long or in stop go trafic. One of the O2 sensors must be "on the edge". It goes out again after a number of start stop cycles.

Hope that helps

Mac
 

·
LEGACY VENDOR
1995-2002 Range Rover P38A
Joined
·
2,064 Posts
Discussion Starter #5
Thanks MAc...

Scotty
 

·
LEGACY VENDOR
1995-2002 Range Rover P38A
Joined
·
2,064 Posts
Discussion Starter #6
You were right the (CEL) went off it took a week and I had to scare it, by going to my friends shop a couple hours away, his T-4 gave us a code of 314 engine misfire....

Scotty
 
1 - 6 of 6 Posts
Top