RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
Hi all,

I've only had my RR for a few months but boy has it given me grief!
Most issues have been related to the alarm/BeCM interaction, so I've had the remote module deactivated and have been using keyed entry for a couple of months now. This has served me well, until today; this morning I put the key in the door and turned it to unlock, the lock pin came up a little way but not quite fully, and nothing else happens (usually all four doors unlock no problem). After reading a few other people's threads I think it sounds like it's driver's-door lock-actuator related, so my questions are:

1) would you agree?
2) how the hell do I get into the car to find out?

All help is most welcome.

Cheers,

James
 

·
Registered
Joined
·
37 Posts
Discussion Starter #3
haha thanks. I managed to get in by holding the key in the open position whilst pulling the handle. I'm sure that was the first thingI tried, but I tired it again and it worked. The alarm went off and the engine was immobilised but after a fair bit of [email protected]%king about with the lock and handle the lock suddenly started working again. I'll be taking off the doorcard and looking at the actuator tomorrow.
 

·
Registered
Joined
·
541 Posts
Good luck, this will likely drive you mad at some point. The dealer went through no less than 4 "new" replacement actuators when trying to fix my issue after the Rover locked my wife inside the car one night. Hopefully on your side of the pond they have some good stock in working order.
 

·
Registered
Joined
·
405 Posts
I went through two before a good set was installed, and I thought I was having bad luck! Hopefully the first is a charm for ya!
 

·
Registered
Joined
·
37 Posts
Discussion Starter #7
I had a look at the door gubbins and all seemed fine! Cleaned it up a bit and squirted a bit of WD40 around the place for good measure. Now the door's back together and no more problems so far except the speaker now rattles with bass, so I'll be taking the card off again very soon! One thing though - could this problem have been caused by the BeCM rather than the actuator?
 
1 - 7 of 7 Posts
Top