RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
349 Posts
Discussion Starter #1
Hey all,

Couple of questions regarding my '03 HSE....

1. The central locking is totally inop. I've not checked the fuses yet, so I'm hoping that's all it may be, however the interior dome lamps aren't functioning either. Is there anything common that fails and in turn knocks these two features out?

2. More annoyingly, everytime I get into the truck, I get this clicking noise coming from behind the clock area. It almost sounds like if the clock were trying to adjust itself but kept getting hung up. This clicking noise happens for maybe 5-10 seconds right after you open the driver's door then goes away and is immediately followed by the nav screen lighting up when you put the key in. Any coincidence?

Thanks in advance for any help!
 

·
Registered
Joined
·
77 Posts
hi, does your steering wheel adjust ? if not that clicking could be that its stuck and its trying to move to your position.
regards
ian
 

·
Registered
Joined
·
349 Posts
Discussion Starter #3
Ian,

Steering wheel doesn't seem to adjust upon door opening, but when I do it using the "joystick" on the side of the column, it works fine without any noise.
 

·
Registered
Joined
·
2 Posts
yup , i had the same problem from 2 month ago, every time i lock the car then unlock after 10-15 min i hear the clicking sound in the dash, i did too many search.......and the problem seems is the ( air condition), and also i have battery drain, because of this clicking thing that runs all night long, and after searching i think it might me(95%) the ac /heater fan blower resistor,i ordered today from ebay fro 80$,but i made sure before to make sure if thats the problem, i took the fuse off for the air condition,guess what???? no humving fan or clicking when entry..... the fuse number is 12, give it a shot.....and see how it goes
 
1 - 4 of 4 Posts
Top