RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
506 Posts
Discussion Starter #1
Quick question guys :)

I researched the above issue and it all points to either low battery voltage and or reseting the 30 amp audio fuse .

I dont have access to my manual at the moment and would like to ask where is the audio 30 amp fuse located?

FYI, all was working prior, then got gasoline and after that cannot select CD option and volume on steering knob does not

work either. :-(

Thanks,
Pokerplayer
Mike
 

·
Registered
Joined
·
65 Posts
I think what is happening is that you press the CD display button (ex: cd 4) to quickly then hit something else. This happens to me when I am being too quick. Essentially, the volume becomes inaccessible on the steering wheel + it is impossible to switch to a different CD. The radio works fine, though, as does bluetooth. Not the CD though nor can you remove the CD cartridge as it becomes basically 'stuck'.

What I do is walk away from the truck for a few minutes & when I come back I restart the vehicle & things are back to normal (for a Range Rover). The CD cartridge is sticking out & the issues mentioned before are long gone.
 

·
Registered
Joined
·
506 Posts
Discussion Starter #3
Galen said:
I think what is happening is that you press the CD display button (ex: cd 4) to quickly then hit something else. This happens to me when I am being too quick. Essentially, the volume becomes inaccessible on the steering wheel + it is impossible to switch to a different CD. The radio works fine, though, as does bluetooth. Not the CD though nor can you remove the CD cartridge as it becomes basically 'stuck'.

What I do is walk away from the truck for a few minutes & when I come back I restart the vehicle & things are back to normal (for a Range Rover). The CD cartridge is sticking out & the issues mentioned before are long gone.
Thank you! That is what exactly happened. I was trying to switch to a different cd too quickly and got stuck. I basically walked away and got back and finally the magazine was half way ejected. Re-loaded it in and all of sudden it's working. :)


Thanks again.

Mike
 
1 - 3 of 3 Posts
Top