RangeRovers.net Forum banner

1 - 11 of 11 Posts

·
Registered
1995-2002 Range Rover P38A
Joined
·
1,365 Posts
Discussion Starter #1
Hi All,

My Nano reports camshaft sensor not working.

Would this make a big difference to the engine running?

I think it has a flat spot ........ BUT, I also swapped the MAF recently for no good reason, so the replacement could be iffy.

Is it ok to drive like this?

Cheers.
 

·
Premium Member
Joined
·
2,565 Posts
well RAVE say's it would be difficult to detect by the driver, it will either be spot on or one revolution out, mine gave the same/similar code but it was caused by oil from the rockers leaking (cleaned PCV hoses) into the Camshaft connector below it. they are very reliable sensors, i think that that code can also be thrown sometimes with (or to do with) the CKP
 

·
Premium Member
Joined
·
1,036 Posts
The engine will bank fire - ie,not inject sequentially,it also wont run closed loop,so it will just do what it can to keep going.Best sort it out sooner rather than later....
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
1,365 Posts
Discussion Starter #4
Thanks for the replies.

I'm going to swap the MAF back (there's nothing wrong with the original), clear faults, stare at a wall, whistle God save the Queen, and scan again.

I should mention that the engine was replaced with a surplus, low mileage unit from Japan.

AllyV8 - you mean that all cylinders in one bank will try to fire at once? Cripes! Sorry, what does "closed loop " mean, exactly?
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
1,365 Posts
Discussion Starter #5
Hi Mods,

Are BBS products or discussion of them banned here?

Just asking.
 

·
Administrator
Joined
·
27,834 Posts
Hi Mods,

Are BBS products or discussion of them banned here?

Just asking.
Not at all, why would you even ask. The only guideline is that diagnostic gear be discussed in the diagnostic equipment forum.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
1,365 Posts
Discussion Starter #7
Hi All,

Did an adaptive reset and it is MUCH better.

Going to check if it still has the cam sensor fault.
 

·
Registered
Joined
·
267 Posts
@Spiggytopes, how are you getting along with the Nano? I'm thinking of getting one of these and would welcome your review.
Cheers

(better in the diagnostics section though)
 
1 - 11 of 11 Posts
Top