RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi everyone

Would really appreciate some advice on what may be causing a strange fumey type cabin smell in my 4.4 Uk spec SDv8 that is now just over a month old...

Basically Ever since I have had the car I have noticed a low level fumey type smell coming through the vents. The smell is most apparent if I am hitting the throttle and then get to a set of lights whereby as soon as I stop after about 10 seconds later I get this sort of burning plastic smell through the vents.... It can also be created sometimes when changing temp from on blower by a few degrees without air con.

My dealer has suggested it is engine coatings that have not burnt off, the car has done 1000 miles and the smell has not got any better. I have had 3 new diesels jeeps in last 5 years from BMW and never experienced anything similar... He says that's changing temp will suck air in from engine hence the smell is more apparent.

I have a 6 month old baby and maybe I am being paranoid but I don't think this smell is normal as I would of thought other RR owners would mention it, on a quick look on this forum it doesn't seem the case

Any ideas? If it is the coatings would they not be gone by 1k miles?
 

·
Registered
Joined
·
130 Posts
Definitely something is wrong with the AC system most likely filters not in correct position. Already someone posted same problem I suggest you read that topic for more info.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
1 Posts
Hi
They know they have a fault but can't fix mine been into dealer 3 times without a fix, it's ok in the summer but as soon as the preheater kicks in it becomes a problem to the extent that I just use my wife's Evouque, my advice to anyone buying the all new RR don't its a waste of money I have been buying Landrover products since 1990 am on my 10th vehicle and this is the worse value car ever, I have asked for them to take it back and they won't I can't sell it with the problem, and I have to avoid driving the car, when the temperature is below 16 degrees when pre heater kicks in.
 

·
Registered
Joined
·
235 Posts
It is quite disturbing...yet another reason I got rid of mine...musty smell when I kicked on the heat and a complete crap Nav system on a $100K car?? In addition to a host of other QA related issues...not right.
Hi
They know they have a fault but can't fix mine been into dealer 3 times without a fix, it's ok in the summer but as soon as the preheater kicks in it becomes a problem to the extent that I just use my wife's Evouque, my advice to anyone buying the all new RR don't its a waste of money I have been buying Landrover products since 1990 am on my 10th vehicle and this is the worse value car ever, I have asked for them to take it back and they won't I can't sell it with the problem, and I have to avoid driving the car, when the temperature is below 16 degrees when pre heater kicks in.
 
1 - 5 of 5 Posts
Top